Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Grand Cherokee, starting problem after getting fuel injector serviced

Join Wrangler Forum Today


Thread: Grand Cherokee, starting problem after getting fuel injector serviced Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-26-2011 01:04 PM
SusanH I did take the car back into the repair place later, and they told me the fuel system is losing pressure, and they believe it to be the fuel pump. With parts and labor, it is too expensive for me to be able to afford to repair at this time.
09-27-2010 06:04 PM
kik This type of problem usually occurs with FI vehicles when an internal leak in the fuel pump or regulator allows fuel to leak back into the tank and you lose pressure. That's probably the reason you have to crank it a few times and it then starts. It builds pressure which enables the fuel to properly pass through the injectors. Not enough pressure, no start situation. Your fuel pump may technically not be "bad" but the seals in it probably are. I would go with the regulator first, then the fuel pump. Remember, it's not that the pump isn't working, it's that it is allowing the system to not maintain pressure after you turn it off. When you turn it on then off then on again the system is building the pressure needed to start the engine. Good luck even though you're not driving a Wrangler.
09-27-2010 05:46 PM
SusanH Thanks, I'll give that a try. (jeepforum.com)
I don't believe it is the starter as it cranks with good speed, and the problem didn't start until it got serviced. Acts like there is no fuel for it to use until after it has cranked. I can hear the hum of the fuel pump before I turn the key all the way on, so I know that is working OK.

Thanks!
09-27-2010 05:35 PM
KBR97 Take it somewhere else besides the dealer, try a privately owned auto mechanic shop. They will be cheaper as well.

You mentioned your nervous about wearing out the starter motor, but reality is that could be the problem. Your starter could be going bad. It could really be a number of things....internet diagnostics arent easy, lol.
09-27-2010 05:32 PM
Kohrs93 Try jeepforum.com you'll get more help there.
This forum is specifically for wranglers.
09-27-2010 05:24 PM
SusanH
Grand Cherokee, starting problem after getting fuel injector serviced

I got my 1995 Jeep Grand Cherokee Laredo tuned up about 4 months ago. They also told me it needed a servicing done on the fuel injectors. In the 8 years I've owned this car, it has never been a problem starting it, even at 40 below zero. One crank, and it starts. It has had a cracked exhaust manifold for a few years, but we've been unable to afford to fix it. However, that didn't seem to ever cause a starting problem.

I took the car back to the repair shop (at a Chrysler dealership) and told them about the problem I'd had since their servicing job. They said it was because of the manifold. I told them it has always started right away. They kept it for 2 days, and the only thing they could do was tell me it was NOT the fuel pump. I had told them the fuel pump was replaced 5 years ago, and I didn't believe that was the problem. I have not been able to take the car back, as it is the only vehicle I have and they don't have a loaner car, and I have to drive to work.

What do you think the problem could be? After it sits for more than about 15 minutes, it is hard to start. I'm going to wear out the starter motor. I've found that if I let the engine turn over for 2 or 3 seconds, and then stop and try again, it will start usually the 2nd or maybe 3rd time of doing that. But winter is coming, and I'm going to use all the cca's on my battery just starting the car.

HELP!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:38 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC