Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Heater Fuse

Join Wrangler Forum Today


Thread: Heater Fuse Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-30-2010 05:23 PM
krutj
Quote:
Originally Posted by Robs20104dr View Post
Could be the cable to the heater core box also. I install some audio stuff and my cable popped off.
That's a good idea.....wonder if the OP had the dash apart?
09-30-2010 04:17 PM
Robs20104dr Could be the cable to the heater core box also. I install some audio stuff and my cable popped off.
09-30-2010 04:15 PM
krutj Yeah, not a fuse issue, probably a thermostat. Take it in, get it fixed under warranty.
09-30-2010 10:54 AM
GREEN-MACHINE if the fan blows, you don't have a fuse problem you have a heater core problem.. reach under the dash and touch your heater core. if its cool or luke warm try back flushing the heater core. oh and check the T-STAT.
09-30-2010 07:13 AM
TDCoffee
Heater Fuse

I realized yesterday my heater isn't working-the fan blows, but no hot. (09 JKU). I checked the fuses, but couldn't find one clearly labeled "heater". Found a few with hvac, but those all looked fine.
Is there no fuse unique to the heater?- was it those hvac fuses?

It is of course still under warranty, but I thought I'd trouble shoot the simple stuff before bringing it in.

Any thoughts?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC