Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Loud Squeal From engine Compartment ITHINK?

Join Wrangler Forum Today


Thread: Loud Squeal From engine Compartment ITHINK? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-01-2010 04:53 AM
robbiecc had a pig squeel when i 1st started on cool mornings and turned on the heater. once warmed up it was fine. tightened the belt and it's gone

note-when getting new serpentine belt, take the number off the old one-good chance you'll get the wrong one if you let them look it up. read it here alot and just happened to me. put the old one back on to take belt back and tightened the old one good-new one still in the package and squeel gone.
10-01-2010 12:21 AM
caleb-97 Loud squealing makes me think it is probably a bearing somewhere. Try to isolate the sound more. If it is under the hood it could be something like a fan clutch bearing or idler pulley, if its from the trany its probably your throwout bearing.
09-30-2010 11:45 PM
xX02wranglerownerXx
Loud Squeal From engine Compartment ITHINK?

it takes a while but when i drive this loud squeal comes out of the engine compartment or the transfer case i think. can some one please help ive run out of options.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:54 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC