Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Blinker Problem Solved!

Join Wrangler Forum Today


Thread: Blinker Problem Solved! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-07-2010 08:15 PM
BigSahara Thanks guys. Just trying to help the other jeepers out there.
10-07-2010 06:33 PM
Jerry Bransford Good job, though the very first suggestion made to your initial post was that it was very likely missing its ground.
10-07-2010 06:10 PM
Dockman4 Good job, and thanks for the post...you just saved some of us from a major headache. Mine work fine now, but I'm sure my day is coming. Thanks
10-07-2010 06:00 PM
BigSahara
Blinker Problem Solved!

So in a previous post I was having trouble getting my right blinker to work when the headlights were on only. I followed some instructions left by fellow jeepers but was disappointed when none of them worked. I then stumbled upon a genius solution. Here's what I did:

I traced the blinker wires back to the ground on the back of the radiator support. I removed my ground wire from its original location to a cleaner one and still the light would not blink. Next I tried messing with the tail light wiring and that did not work either. Then it hit me. I decided why not look at the actual bulb even though it worked. I yanked out the bulb and out came about an oz. of dirt from inside of the connector. The positive wire on the bulb was completely missing and in its place was green crust. After I removed the bulb what do you know, I could hear the blinker clicking from inside the jeep. I replaced the bulb with a new one and sprayed the inside of the socket out with MAF Cleaner thinking I solved it. Nope. Still wouldn't work. Now thoroughly frustrated I went back to pep-boys to replace the other blinker bulb in the front of the fender and met a guy who used to work at Chrysler in the parking lot. His solution, hit the fender. I did that a few times right on the blinker housing and bam the light went from dim solid on to bright blinking. Now it was official. The blinkers worked when the headlights were on or off. It turns out the bulbs were losing their ground inside the socket and the sockets just needed to be cleaned and eventually replaced.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC