Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Weird smell at 45MPH+

Join Wrangler Forum Today


Thread: Weird smell at 45MPH+ Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-18-2010 07:10 PM
jeeperman Depending on your limited slip that you had installed, as little as 1/2 pound of pressure difference in the rear tires could cause a lot of heat to build up at speed... Check to see if the pumpkin is getting hot, and see if the belt is unusually warm, other than that, it might just be oil that dripped on something, and gets hot when you run the engine hard...
12-18-2010 07:01 PM
Jeegar I tried to search but i'm hitting a dead end because when i stop and try to smell it its not smelling any more.. bumms me out..

Any one can point me towards how to trouble shoot this??
12-18-2010 06:59 PM
jeepjones Keep searching, cause we can't smell a thing through the computer. You'll have to find yourself.
12-18-2010 06:49 PM
Jeegar
Weird smell at 45MPH+

I have a 97 Jeep Wrangler, 4banger. Recently I got a rear differential changed. Went from an open diff to limited slip (posi) differential.
After I got it done, there has been this weird smell coming when i hit around 45 MPH. when my window is open, it is strong and when its closed it is not at all.
The closest i can relate to that smell is like smell near lot of factories. It is definitely not coolant and most likely not oil.
I got it checked and when hoisted the jeep, there was no oil or any thing falling on the exhaust system. It does not smell when I stop. Tried to smell to the source of the smell but failed.

Also i recently got the idle pulleys (on serpentine belt)changed.

i have no idea where the smell is coming from or what it is..

It is kinda hard to explain what it smells like but i gave the best description i could..

Any help suggestions would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:13 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC