Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Squealing noise

Join Wrangler Forum Today


Thread: Squealing noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-20-2011 07:53 PM
LuvMyTJ
Quote:
Originally Posted by wm7888 View Post
The sound is actually coming from the Camshaft position sensor/Oil pump drive. Found out it was supposedly replaced Oct 7, 2006. It makes this noise when you first crank it. Then about 5 min later it quits. Oil gauge does not drop when it squeals, it stays in normal range. I was quoted a price of $259. plus tax to repair at a authorized jeep dealership.
I thought this was a known recall? If so, it should be free. I would ask before I paid to have it done.
01-20-2011 06:45 PM
wm7888 The sound is actually coming from the Camshaft position sensor/Oil pump drive. Found out it was supposedly replaced Oct 7, 2006. It makes this noise when you first crank it. Then about 5 min later it quits. Oil gauge does not drop when it squeals, it stays in normal range. I was quoted a price of $259. plus tax to repair at a authorized jeep dealership.
01-18-2011 04:55 PM
TexasT Wow...that sounds alive. I had a tensioner pulley that made some strange noises on my 99. I know yours does not have the same belt route but it does have a tensioner.
01-18-2011 04:12 PM
jasonwrangler its a 2005 so maybe the CPS gear is chewing the cam gear?
01-18-2011 03:34 PM
HyperBuzzin Does it always do it, or stop once it's warmed up?
01-18-2011 03:03 PM
Quickdraw Thats weird! maybe you fan is tapping your shroud.
01-18-2011 01:43 PM
wm7888
Squealing noise

Can anyone give me an idea of what this noise is. 2005 Wrangler Sport. 70,000 miles, no lights on drives good
http://http://www.youtube.com/watch?v=5QVQNcDPzYg

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC