Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Busted the rear body mounts!

Join Wrangler Forum Today


Thread: Busted the rear body mounts! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-09-2010 11:34 PM
multisonic This was the very last thread in the TJ section. I decided to bring it back to life, for no real reason other than I am VERY bored. And now for the relevant comment that makes it ok.

Gee, I sure hope that never happens to me!

There.
04-09-2005 06:47 PM
JeepCrawler98 ...Part II


And here you see the bottom of the tub, with the two original body mounts of course, then the bolts sticking out in the bottom are to help sandwich the body to the new crossmember.

04-09-2005 06:46 PM
JeepCrawler98 Ok, here is what the body mount's did to the body's crossmember:

Looking from the top past the cut away body material. All the cracks, except those surrounding the body opening - are due to stress


Here we are looking through an inspection hole through the frame to the body, another crack


And here are the pix of the re-inforcement looking from the top. There is a 1/4" new crossmember welded across the tub, but you can't see that because the gas tank is in the way


...
04-08-2005 01:57 AM
JeepCrawler98 Hahaha - well it definitely was the same type of stuff, but I didn't have my camera with me .

The frame is in good shape - it's the body reinforcement that got completely torn to shreds! I plasma cutted out the tub's skin covering it up, stress cracks up the wazoo! I replated that part of the tub with 1/4" plate that welded in place, and had the bolts go through there today. I took it down some bumpy roads, and over this really shitty railroad crossing. I dont think the rear has ever been this quiet since I got it, so it should be good. Regardless, I'll still probably redo a few things here and there, even though it's probably stronger than it's ever been right now. I'll get some pics of the cracks tommorow, I need to get them from my brother. I forgot to take the pics of the new reinforcement, so I'll see what I can take without removing the gas tank again.

I think I may use these photos as part of my anti-body lift campaign; I think the truth might upset a few people
04-07-2005 08:53 PM
Rawkon lol geez dude what were you doing, trying to get on the cover of that rock crawler mag again???
04-07-2005 08:16 PM
Ghettobird8
how the frame

Did your frame get bent any this time or when you got your crossmember bent.
04-06-2005 09:18 PM
JeepCrawler98 You will - probably this weekend... I hope
04-06-2005 06:01 AM
deverhart ouch :-/ I wanna see pics!
04-06-2005 12:00 AM
JeepCrawler98
Busted the rear body mounts!

Well I finally figured out what's been making these God awfull squeeking sounds in the back of my TJ after my last wheeling trip. It turns out I ripped out most of the body mounts behind the rear seat - now the truly cool part is, that I do NOT have a body lift (so let that be a lesson - stress is still crazy without a BL!). Since the body mounting points on the tub are completely non useable (there's a nice big circle where it fractured and tore out of the tub) I'll be fabbing some new ones out of 1/4" plate. So the moral of this story - always suspect body mounts, and never use body lifts!

I will keep you guys posted and get some pics when I get everything all buttoned up again.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC