Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Leaking tranny or transfer case?

Join Wrangler Forum Today


Thread: Leaking tranny or transfer case? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-19-2011 10:11 PM
Lariatryder Post some pictures and part numbers when you get it figured out. I think mine is leaking too.
01-19-2011 10:04 PM
sppfields bought mine at oriellys just the other day. had 1 in stock, got the other the next day. it doesnt matter which one is leaking. while you are in the just replace both. but if you are leaking trany fluid, its the transfer input seal, if you are leaking oil, its the transmission output seal. go to morris4x4 and get the part numbers.
01-19-2011 08:47 PM
Square_Eyes Bump
01-19-2011 05:48 PM
Square_Eyes
Leaking tranny or transfer case?

My dad and I were wrenching on the jeep Monday night when I realized that oil was dripping off the skid plate underneath. I unbolted the skid plate to get a closer look and the transmission and transfer case fell on me after my dad jacked it back up I got a closer look at where it was leaking, it's coming from the mating point of the transmission and transfer case. I've tried looking up what seals I'm gonna need and I've narrowed it down to an output shaft seal for the transmission or the retainer seal for the transfer case, I called napa to see if they had either one and they told me that nothing even comes up in their computers?! Has anyone recently had this problem and fixed it and if so what parts did you need? Thanks for the help guys!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:53 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC