Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Oil Pressure reads High

Join Wrangler Forum Today


Thread: Oil Pressure reads High Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-24-2011 12:13 AM
Ribs2234 No matter what my rpm is at, idle or full throttle mine reads maxx
01-23-2011 09:38 PM
YJPunisher213 Mechanical gauge should be your FIRST STEP! Dont want to replace anything over a faulty gauge. Mine stays pegged from the time its started to the time I turn it off. I have replaced the sending unit, oil filter, breather tube, oil pump, etc. Nothing has changed. I put a mechanical gauge on it and it reads normal. So I spent a couple hundred bucks for nothing.
01-23-2011 09:18 PM
n2trucking that gauge can move around with a bad sendor even with low oil pressure like in ranges that are deadly for your motor so it's important to replace it or put a mechanical setup on it which are more spot on but if your like me i like the factory look
01-23-2011 12:50 PM
wylie coyote sounds fine to me. at least I know it's got pressure and isn't doing anything wierd runnin/noisy wise. thx.
01-23-2011 11:21 AM
kik 99.9% of the time it's the sender switch. I replaced mine on my 89 4.2 3x already because I liked it to be at least in the proper range. I'm not replacing it again.
01-23-2011 10:26 AM
wylie coyote Mine has done it since I got it- except it's 70-80 above 2200 rpm. At idle it's about 40. Usually it's something like a plugged oil filter or a bad sender or gauge or bananas in the crankcase. (Not likely). Mine just had a filter and oil change, so......I'll be looking in on this thread.....haven't had the time to check the other thngs yet.
01-23-2011 10:06 AM
fredvic79
Oil Pressure reads High

Hey I have an issue with my engine oil pressure, it is starting to read 60-70. What are some things I can do to fix the problem and can I still drive it?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC