Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > 2005 Jeep Wrangler w/ 4" Lift

Join Wrangler Forum Today


Thread: 2005 Jeep Wrangler w/ 4" Lift Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-09-2007 09:52 PM
AzTJ
Quote:
Originally Posted by EnigmaMan View Post
The only one I couldnt tighten up was the rear track bar because it had a torex head on it and a bolt that was welded to a flat plate on the other side. so I couldnt get much torquing of that one. Why do people use Troex (SP?) 5 star bolts? Those bolts are stupid in my opinion.
THat torx bolt is factory... you'll learn to love this Jeep if you dispise torx head bolts
07-09-2007 09:50 PM
EnigmaMan Alright so I went under the jeep tonight and tightened up all of the stuff mentioned, most of the bolts were anywhere between 1-3 full turns loose before they tightened up. That took care a lot of the swaying motion of the rear end

The only one I couldnt tighten up was the rear track bar because it had a torex head on it and a bolt that was welded to a flat plate on the other side. so I couldnt get much torquing of that one. Why do people use Troex (SP?) 5 star bolts? Those bolts are stupid in my opinion.

BTW, I saw the relocation bracket for the rear Track-bar, that looked good.

The next step is to try and get a front end alignment and check that caster / camber angles and hopefully that will tighten it up even more!

Thanks for your help on this. I think this is the reason why the jeep sat on the lot for 54 days and almost went to auction because nobody liked how wobbly it was.
07-09-2007 07:54 PM
Triple88a ^bluvikng is one smart man with lots of experience... I'd trust him
07-09-2007 07:39 PM
bluvikng Yeah, you know, the one I mentioned with the relocation bracket...........
07-09-2007 07:29 PM
4.0l sahara yes there is one in the back.
07-09-2007 06:30 PM
EnigmaMan Yeah that sounds like a pretty important part of the suspension. That could explain the wobbly feeling at high speed. Is there a track-bar for the rear end as well?

I will double check and make sure this isnt loose as well.

Thanks for the heads up!
07-09-2007 06:12 PM
Triple88a
Quote:
Originally Posted by 4.0l sahara View Post
the track bar keeps the axle centered.
what he said^ if you remove the track bar the front tires will move left and right.
07-09-2007 05:55 PM
4.0l sahara the track bar keeps the axle centered.
07-09-2007 05:06 PM
EnigmaMan The only thing I wasnt familiar with was the "track bar"

Typically I have delt w/ Traction bars on Leaf spring setup's or "Anti-sway" bars on front / rear ends where the sway bar links are connected to.

I am more familiar with working w/ IFS instead of solid axle vehicles thats why I was a little confused by this.

Thanks for the heads up on the Track-bar though. What exactly does the track bar do? and why does it only connect to the passenger side front tire?
07-09-2007 04:45 PM
bluvikng Study this picture, and become familiar with your steering components.

http://www.4x4xplor.com/images/align...lignment01.jpg
07-09-2007 04:39 PM
EnigmaMan Alright cool, Thanks for the heads up. with the pinon angle and the shocks.

sorry for asking so many questions, I just want to make sure that I cover all the bases as my wife is going to be using this as her daily driver and it feels crazy tipsy even at 45 let alone 65mph.

Tonight when I get home I will be sure to tighten all the bolts / locations that you mentioned and then take it in and get the front end aligned at Firestone this week sometime and also mention to them as mentioned in troubleshooting steps about the camber / tow angles.

I'll post my results later tonight once I check all the bolts for tightness.

Thanks again for all your technical help!
07-09-2007 04:22 PM
AzTJ He just keeps asking questions and not really responding... almost frantic like
07-09-2007 04:06 PM
bluvikng I guess my answers are transparent. You have an unlimited. It has a longer drive shaft, no problem with the pinion angle, I assure you. You don't even have the dreaded slip yoke. Your shocks are mounted in the correct position, as it is where the factory placed the brackets.

Don't over complicate things. Check the things I mentioned earlier, if that is all good, then go from there. That is the first place to start trouble shooting.
07-09-2007 03:57 PM
AzTJ This is the "Trac Bar"


And a "traction bar" is something completly different.

If your rear shocks arn't rubbing on the spring they should be ok... but if they are rubbing, they should be inverted. And there is only mounting location for them.

No - your rear upper control arms appear to be stock and are not adjustable, you would need to purchase some new adjustable ones in order to correct the pinion angle.

I'm thinking that they guy that lifted it didn't get it aligned properly and just did it "quickie" in his driveay to get it driving right.
07-09-2007 03:37 PM
EnigmaMan Are these rear shocks mounted incorrectly and should be mounted in a different location?

Still a little confused on that part.
07-09-2007 08:36 AM
EnigmaMan Also one othe thing that I noticed is that there is a vibration around 42-47mph. I think this is due to an incorrect pinion angle on the rear axle, are these adjustable? Also what should the pinion angle be so I can vertify / correct this as need be?

I found this in the rubicon express trouble shooting information:

Acceleration vibration: Caused by the pinion being too high in relation to the transfer case output shaft. Adjust upper control arms or cam bolts (both optional) to lower pinion accordingly.

Deceleration vibration: Caused by the pinion being too low in relation to the transfer case output shaft. Adjust upper control arms or cam bolts (both optional) to raise pinion accordingly.


General vibration: Caused by excessive angle on the rear drive shaft. Very common on vehicles with 2” or more of lift. It is typically acceptable to install the included transfer case drop kit and use a standard drive shaft. Optional cam bolts (RE1475) allow some adjustment of pinion angle and may be needed (see acceleration and deceleration vibration troubleshooting above). For best performance, install optional upper adjustable control arms (RE3783), a slip yoke eliminator (SYE) kit (or CV yoke on RUBICON model) and CV drive shaft. Adjust pinion so it is 2 degrees below parallel with CV drive shaft (see acceleration and deceleration vibration troubleshooting above). A transfer case drop kit can usually be omitted with a CV dive shat. r f

High speed wobble: (I think this is what I am feeling)
This is fairly common with y-type steering on lifted TJ's. It is a condition where front tires will shimmy after hitting a bump. Avoid bias ply tires and wheels with excessive offset. Check for worn or loose parts. In most cases a reduction of positive castor will eliminate this condition. A good rule of thumb is minimum factory caster and maximum factory toe in. Note that lift heights increased with coil spacers (or taller coils) may exhibit wobble that cannot be corrected with alignment.

Bump steer:
Caused by improper relationship of drag link and track bar. To correct, center axle again following the instructions supplied with the track bar. Next determine the neutral position of the steering wheel. Adjust the drag link to center the steering wheel.


I think who ever installed this Lift kit really messed things up and didnt install it correctly. Im going to have to go over the installation with a fine tooth comb to make sure its correct.
07-09-2007 08:24 AM
EnigmaMan Ah nice to know about that, do you mean a 4 wheel alignment or just a front end alignment? or is this an actual Axle alignment where its true and not crabbing down the road?

Also when you mentioned about the shocks, which way are they supposed to be mounted? Maybe the geometry of the shocks might be what is doing it if they need to be reloacted to another location.

Also what is the front Traction bar? Is this the same thing as the anti sway bar shown in the this picture?




Thanks I will be sure to check all of the bolts and make sure they are tight including the pitman arm! (thats prob the most important one! lol)
07-09-2007 07:35 AM
bluvikng Here are a few issues that I have dealt with. Make sure your pitman arm is tight. Check the big nut, that holds it on, sometimes the will self loosen. Check all the bolts, holding your upper, and lower control arms. I had two, that broke on my front axle. Check the drop bracket, (relocation bracket) on your rear axle. Make sure all the bolts are tight. It does not hurt to put locktight, on those bolts. Get underneath the jeep, and physically crab a hold of all the mentioned components, and see if you can get them to move. Everything should be very tight, and with time, they do tend to loosen up. This is something that should be done, on a regular basis.
07-09-2007 01:23 AM
AzTJ Ok - I'm more than positive that its a Rubicon Express 3.5" Standard lift.

Yes - it appears to be a Dana44 axle

The bushings you describe are bumpstops that limit the upward travel of the axle so that the tires will not run the fenders.

Its a solid quality lift... but if its swaying, the guy might not have had it aligned properly. I notice that the front track bar isn't adjusted out any.. are the front tires sticking out farther to the right a bit? I'd get it alligned and see how that does, but even with the stock tires on there it shouldn't drive any different.

on a different note - inspect those rear shocks and make sure they are not rubbing the spring pads. Because the shocks are usually mounted the other way around.
07-09-2007 12:47 AM
EnigmaMan Below are the photos of the rear end. Like I say I am not sure what kind of a lift kit it is, or if its any good (quality wise). Maybe these photos might help figure out what is causing this feeling.

BTW, Also on the front springs it looks like there is a rubber bushing thats 1" tall on the top and bottom is this normal or is this used to add ride height?

Thanks for your help!


Is this a Dana44 Rear Axle?


07-09-2007 12:33 AM
AzTJ Do you have a pic of back of the rear axle on the driver side? If there is a grey/silver bracket, it might be a RubiconExpress 3.5" Standard Kit with an added track bar.
07-09-2007 12:30 AM
AzTJ Yes the front is a Dana30 axle...

well it looks like just a regular 4" spring lift.. the control arms look to be stock, and you have an adjustable front track bar. Still, even with stock tires it shouldn't be swaying if aligned right and tires are balanced.

Those shocks prolly arn't Rancho's... my guess is the lift is a Tuff-Country or 4WDHardware lift.

Someone else might be able to chime in a give ya bit more advice though.
07-09-2007 12:08 AM
EnigmaMan Sorry for the bad Lighting, It was pitch black outside but you will get an idea..

I checked the pressure, All of them were @ 30psi and I pumped them up to ~40PSI and it seemed to help some but didnt fix the horriable handeling. I will be upgrading to some 16x8" rims with a set of 285/75/R16 D|ck Cepek Fun Country II's (Load D range) here in the next few weeks. Will this help out the handeling or make it worse?

BTW, Is this a Dana 30 front end?







Rear Passenger Side
07-08-2007 11:40 PM
AzTJ Any closeup pics of the components? Control arms and steering system in the front?

When you say the Jeep "quivers" is it sever and make you slow down? Or just it just jerk to the side?

The "floating" might be due to the small/skinny tires and the hieght of the lift. Also, check the tire pressure, because if its too high the tires will be riding on the center and it will want to sway a bit.
07-08-2007 11:01 PM
EnigmaMan here are the photos.

I think this is a 4" lift kit, and it looks like it has New springs / shocks. What do you think?





07-08-2007 10:42 PM
EnigmaMan
2005 Jeep Wrangler w/ 4" Lift

I just bought a 2005 Jeep wrangler Unlimited- hard top yesterday and Im new to the Jeep wrold (the wife used to have a Liberty, but I dont think that classifies as a "true jeep" lol)

This jeep has 18,000 miles on it and has a 4" lift kit. Before the guy traded it in he swapped back to the stock 30x10.5x15" rims and tires.

My question is, This thing feels like it floats around everywhere! it feels worse than a 1970's caddiliac at 65-70mph the front / back end floats around and feels like the tires are running 10psi of pressure. Im not sure if its the stock tires or the lift kit or what. However, the up and down bumps feel normal and stiff.

Everything from what I can tell looks brand new and doesnt look like its a hack job or anything and has Rancho shocks from the best that I can tell.

Any ideas on how to stiffen this thing up so it doesnt feel like its going to flip @ 65mph?

Also 1 other thing when driving down the interstate, it feels like if you hit bumps just right the front end quivers / and continues to shake after you hit the bump. (almost like the front axle is jumping up and down and there arnt any shocks).

Thanks for you help!!

This has the Dana 44 rear end w/ Dana 30 front end. and 3.73 gears w/ Rancho shocks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:58 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC