Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Radiator Top hose HOT! Bottom Ice Cold!

Join Wrangler Forum Today


Thread: Radiator Top hose HOT! Bottom Ice Cold! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-31-2011 05:06 PM
L.A.Offroad Thats what a radiator does.It is a heat exchanger.If you are running the correct temp.and have heat in the vehicle you probably DONT have a problem.
01-31-2011 04:56 PM
dmblair I'd say you have an air lock somewhere in your system (what's wierd though is you have heat, usually with air locks it doesn't like to blow hot air). When your engine is cold pull your radiator cap off and start 'er up and let it warm up. You should hopefully get some burping and what not coming from inside the radiator and the fluid level should drop down a little. Top off the antifreeze and re-cap and see if that helps.
01-31-2011 04:42 PM
dboxjeep
Radiator Top hose HOT! Bottom Ice Cold!

I just bought a 1995 YJ 2.5L with a new radiator and top and bottom hoses.

Temperature here now about 25 degrees outside.

Motor runs 210 dergees. Heater puts out air so hot it will almost burn your fingers!

Right after shutting off the engine I have noticed that the heater hoses, top radiator hose, and radiator top as hot as can be but the BOTTOM hose is ice cold! What is going on. With the engine running still ice cold at the bottom. Could it be that the water pump is not pumping and since it is cold here motor is still running at the correct temp.

Thermostat problems? Can the impeller come loose from the pump shaft?

Looking for answers please from you gurus! !

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC