Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum > Defroster problem?

Join Wrangler Forum Today


Thread: Defroster problem? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-03-2011 03:57 PM
kik I don't know what happened. Have the Bosch on for a year now and not one streak.
02-03-2011 02:16 PM
jk'n I used the Bosch wipers and they were good for about 3 months in the summer and began to streak so bad that I was having trouble seeing at night when it was raining. I ditched them and went with the rainx 16" and those have been working great thus far this winter. You won't see many replacements for the JK as most manufacturers stop at 16" blades. The 16" blades work fine. Regarding the icing problem, if it is really cold, direct the heat at the feet and when stopped, run the wipers. When moving you will be able to turn the wipers off and the snow will just bounce off the windshield and not stick. Keep the heat low in the jeep. This allows the outside of the windshield to drop below 32 and this accounts for why the snow will just bounce off. In icing situations: rain falling through warm air aloft but freezing on surfaces below 32 at the ground, this will not work. The only thing that works for icing situations is blasting the windshield with warm air. I sometimes open the windows a bit to balance the hot air required to keep the windshield warm and keep the interior from overheating. The things we do for our jeeps.
02-03-2011 02:09 PM
NHrubicon
Quote:
Originally Posted by tuffk View Post
Question, where is the ( New Thread Button ) I sure dont see one ???
you have to 'back up' in the 'thread tree'...look up above the 'reply to thread' and see the forum/thread 'listing' there...go to the section you want (like JK forum) and click there...instead of a 'post reply' it will now say 'new thread'...
02-03-2011 01:56 PM
tuffk Question, where is the ( New Thread Button ) I sure dont see one ???
02-03-2011 01:42 PM
tuffk
2008 Wrangler defrost problems

Our 2008 wrangler also has a windshield icing problems, durning cold heavy snow, heater blows well and hot but very little air hits the outter edges of the windshield area, the ice will soon freeze on the outside and then the wipers will begin to fail. Looks like a little design flaw on Jeeps part. I am working on a small plastic clip on air deflector to correct this situation. almost have it perfected, it clips into the current defroster vent to direct some hot air to these outter edge's.
tuffkidder@gmail.com
02-02-2011 04:50 PM
Hellbilly I was thinking of Rain X style of blades.(not necessarily that brand) Had a pair on my last vehicle and they lasted close to 3 yrs without any problems as discussed. I will have to go with 16" though and hope the ppl here are right about them fitting.
02-02-2011 02:54 PM
kik
Quote:
Originally Posted by Lucy3322 View Post
kik, I'm sure this is probably a stupid question. I just got on the Bosch website and selected the information they wanted to get the blades. Got a reply that there were no blades available for this make or model. Where did you get them? Thanks
Not a stupid question. They don't list it for a JK because technically JK's have 15" blades. Just go to amazon.com and you can get the Bosch Evolution 16" blades (4816). They come one to a pack. $9.09 each. Don't click see if it fits. It does fit perfect.
02-02-2011 02:18 PM
Lucy3322 Never heard of such a thing. Where would the wires get power? Sounds expensive!
02-02-2011 02:05 PM
Lucy3322 kik, I'm sure this is probably a stupid question. I just got on the Bosch website and selected the information they wanted to get the blades. Got a reply that there were no blades available for this make or model. Where did you get them? Thanks
02-02-2011 02:01 PM
Trunz150 They make blades with wires through them to have heated wipper blades my dad just put them on his audi and he loves them im gonna look into them and i will post the website when i find it
02-02-2011 01:51 PM
Scooter_Trash Mine does this too. I think it's because the blades sit below the bottom edge of the windshield not letting the heat really hit them them. My plan was to move the wipers up (kind of like on older model YJs and CJs) higher. There is a little over an inch in play before the drivers side wiper would be off the windshield at the top of it's stroke. I took the wiper arm off but there is a small white plastic tab doesn't let you move it higher. I was too cold to figure out how to get the tab off so I ended up just leaving it stock.
02-02-2011 01:41 PM
Lucy3322 Thanks, I'll try them
02-02-2011 01:39 PM
kik
Quote:
Originally Posted by Lucy3322 View Post
Any particular kind of blades in mind?
Bosch Evolution 16" blades are real good. The 16" fit with no issues. A lot better than the stock 15" blades. We put them on our 10 Rubi a week after we got it, based upon recommendations on the forum, and have no complaints.
02-02-2011 01:34 PM
Lucy3322 Any particular kind of blades in mind?
02-02-2011 01:08 PM
Hellbilly Mine also did this a couple of times this winter. I think it is normal as the windshield is not as aerodynamic as other vehicles. I am thinking about different blades next winter though. That may help?
02-02-2011 12:53 PM
Lucy3322
Defroster problem?

Just joined and really don't know where I should post this question. I'm sure somone will let me know. Anyway I bought a 2010 Unlimited this last August. Like it! Yesterday while driving home in a snowstorm, my windshield and wipers kept icing up. So much that I had to pull over every 3 or 4 miles and scrape the glass and clean the wpers. Defroster was going full blast and blowing really hot air against the glass. Is this normal to ice up so badly? Is there something I can do to help it defrost better? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC