Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > high idle problems among others

Join Wrangler Forum Today


Thread: high idle problems among others Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-07-2011 09:39 AM
wesman1 thanks for your help looking for the part but no one seems to carry it... where did you find yours? also one more stupid question, tryin to flush out my tranny but cant get to the fill plug do you need to drop the skid plate to get to it. that would seem like too much work.
02-06-2011 05:59 PM
RednekYJ Replacing the IAC is pretty easy and cheap. My 89yj 2.5 had an idle problem the same as yours and the iac had a short. Really without a mechanic this is just throwing parts at it.....
02-06-2011 04:09 PM
wesman1
high idle problems among others

Just bought my first jeep in october. black 88 jeep wrangler 2.5 L 4 cyl 5 speed. no real problems except ive had to replace the starter twice since. just moved to florida from ny and couldnt wait to get the soft top off but... having trouble with a high idle, idles round 1500 to 1800 rpms in neutral but goes down when shifting through the gears. cannot figure out the problem. ordered a crown tune up kit and awaiting its delivery. hoping that will fix the problem. also having difficulty shifting thru 1st, 2nd and 3rd gears. clutch was nice and worn in but now feels tight when engaging gears. probably low on transmission fluid but cannot get to that damn bolt on the tranny. if anyone has any advice or tips please help me.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC