Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Just traded in my TJ.

Join Wrangler Forum Today


Thread: Just traded in my TJ. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-13-2011 04:15 PM
JeeperJake ...there's nothing like a new Jeep to put a smile on your face....
02-13-2011 03:58 PM
MMJ89586
Quote:
Originally Posted by Chub View Post
66,000. They gave me $10,100 for it. Loved that Jeep, was my first one. Got hooked on driving with the top off (wife loves it) and 4 wheeling with my son. Dog loves it too, she barks when we stop..lol. Just had both rear u-joints put in this morning too. Got that fixed and stopped at a dealer on the way home for the hell of it. Ended up trading her in on the 11'. Sort of stupid spending bucks on repairs then trading it in on the way home eh?...lol. Was looking at and test drove a Red base model. Then I saw a Cosmos Blue one with the upgrade package that they had inside which was about $1,600 more. Told the guy, give it to me for the same price and he has a deal. And bingo...got my new JK....lol.

From my post in the TJ forum


Hi all...I'm stumped. My 04' (6 cyl. automatic, no lift) starts vibrating pretty bad when I hit around 25 mph, it sounds like it's coming from the engine. But if I put it 4wd it smooths right out. Even if I just put in it 4wd drive for a couple seconds and take it out it goes away, until I slow down and have to accelerate again. When it vibrates it also feels like I loose a lot power. Doesn't happen when costing. The harder I accelerates the worse it gets. A little more info if this helps, the 4wd indicator light doesn't always come on when engaged, sometimes it takes 5 or 6 miles....Thx for any help.
Actually that was pretty low miles. I had an 04 wrangler rocky mountain edition a few years ago. The new ones really are different than the older ones. But they're all awesome.
02-12-2011 10:21 PM
banditman Let us know what you think about the differences in the two vehicles once you drive it a while.
02-12-2011 09:52 PM
Chub
Quote:
Originally Posted by MMJ89586 View Post
Cool how many miles were on the 04?
66,000. They gave me $10,100 for it. Loved that Jeep, was my first one. Got hooked on driving with the top off (wife loves it) and 4 wheeling with my son. Dog loves it too, she barks when we stop..lol. Just had both rear u-joints put in this morning too. Got that fixed and stopped at a dealer on the way home for the hell of it. Ended up trading her in on the 11'. Sort of stupid spending bucks on repairs then trading it in on the way home eh?...lol. Was looking at and test drove a Red base model. Then I saw a Cosmos Blue one with the upgrade package that they had inside which was about $1,600 more. Told the guy, give it to me for the same price and he has a deal. And bingo...got my new JK....lol.

From my post in the TJ forum


Hi all...I'm stumped. My 04' (6 cyl. automatic, no lift) starts vibrating pretty bad when I hit around 25 mph, it sounds like it's coming from the engine. But if I put it 4wd it smooths right out. Even if I just put in it 4wd drive for a couple seconds and take it out it goes away, until I slow down and have to accelerate again. When it vibrates it also feels like I loose a lot power. Doesn't happen when costing. The harder I accelerates the worse it gets. A little more info if this helps, the 4wd indicator light doesn't always come on when engaged, sometimes it takes 5 or 6 miles....Thx for any help.
02-12-2011 08:59 PM
MMJ89586 Cool how many miles were on the 04?
02-12-2011 07:58 PM
ESP You are going to love your JK! Congrats on your purchase and choice to get another Jeep. Bring on the smiles while driving her home.
02-12-2011 07:53 PM
MVines Congrats, welcome to the JK crowd!
02-12-2011 06:29 PM
Barrie Welcome
02-12-2011 06:25 PM
J.B. Congrats! Welcome to the Forum! Enjoy!
02-12-2011 02:56 PM
Redjeepmormon Congratulations!!!! Post pics when you get the jeep!!
02-12-2011 02:44 PM
Chub
Just traded in my TJ.

Well I just traded my 04' in on an 11' JK. Hated to give her up, but it was time. Picking her up Monday. Got the 24s package, 17" aluminum wheels etc. Can't wait to pick it up, just happen to be on vacation next week, going to have plenty of time to break her in.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:55 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC