Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > WRONGler!! Body Mount troubles.

Join Wrangler Forum Today


Thread: WRONGler!! Body Mount troubles. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-16-2011 06:46 PM
RIpPeR Ahhhhh, thank you, Sir!
02-16-2011 12:09 PM
village idiot There are two more mounts under the tub above the rear axle. There are 11 total, you found 9 of them.
02-16-2011 12:00 PM
RIpPeR A friend and I tryed loosening the body mounts yesterda=y and force the body straighter onto the frame. To no avail. So my question now is what all to I need to loosed in order to get some play in the body? I found the 3 mounts on each side, two mounts at the back and one mount in the center under the radiator. Any advice is appreciated.
01-06-2011 09:31 PM
RIpPeR Hahahaha...thanks!
01-06-2011 06:50 PM
TexasT I agree...be careful when taking them out cause it looks like the bolt is bent or the mount has been damaged. I too suspect your TJ has had an impact of some kind. If it's not off by much you may want lean a little when you look at it. Straightens right up that way.
01-06-2011 06:18 PM
TroutBumTJ To me It looks as though the jeep may have had an impact to that side at some point. Loosening and realigning the bolts may help but if the threaded entry point to the body is bent it will likely not thread straight vertical. If that's the case you may need to take it to someone and have them bend it straight for you, if that makes sense. You can look at the head of the bolt and tell that it is not truly vertical. Hopefully loosening and retightening will work for you.
01-06-2011 03:35 PM
RIpPeR Yes, with an adjustable track bar...

Here are some pix...

Drivers side looks good


Passengers side is slightly off
01-06-2011 02:45 PM
TexasT Hard to imagine the leaning problem to be associated to the BL. Sounds like it could even be coil spring pads may have been taken out or left out on one or more corners.during the lift install. Pics could help.
How are you planning on centering the axles? I hope it's with an adj track bar.
01-06-2011 02:32 PM
4Jeepn Sound like it took a hit or hit something on that side. can you post some pic's?
01-06-2011 02:28 PM
RIpPeR Yes, I'm at least planning to loosen all the body mount bolts and try to get all the bolts running as verticle as possible (thus meaning the body is on evenly), then re-tightening. I'm thinking this could be why the tailpipe is unusually close to the gas tank and was rattleing before I spaced the bracket for the tailpipe hanger.
01-06-2011 12:27 PM
Middleton I don't think it could do much. Only thong I could think of would be something with front end alignment. But other than that I don't think it could do much. But just to be sure I'd replace tht bushing.
01-06-2011 12:13 PM
RIpPeR
WRONGler!! Body Mount troubles.

Hello folks,

Am new to this forum and hope I'm not repeating a common topic. Recently bought an '05 TJ and have some work to do on the front end (centering the axles is in store for this weekend...been suffering some bad Death Wobble). But I also noticed that the body mount bushings on the passenger side seem to be leaning toward the front a little bit. In other words the body is not mounted perfectly straight onto the frame...even though its very slight. So anyways, my question is what adverse effects could this imperfect sitting tub have??

* Stock bushings...no body lift.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:47 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC