Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Transfer case vs transmission? Grinding noise

Join Wrangler Forum Today


Thread: Transfer case vs transmission? Grinding noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-17-2011 06:52 PM
wmpiehl Yeah, crawl under your jeep and make sure the t-case isn't between gears. Do you have a lift on you jeep?

Also, $2000.00 is way too much for a t-case rebuild. If you did mess up your t-case you can find one on craigslist for under $500
02-17-2011 04:14 PM
Ibuildembig Sounds like it case isn't fully engaged....try moving the stick back and forth a few times and see if that cures it....

WELCOME to the FORUM!
02-17-2011 04:06 PM
SimplyAubs
Transfer case vs transmission? Grinding noise

Hello all!

I've had my 2004 TJ (automatic) since 2005 and have never had a problem. I love it! However, 2 days ago it started making a "grinding" noise...almost like there was something underneath that it was dragging. A few hours later, I put it in reverse and it did go in reverse, but the grinding/dragging noise was loud. I put it in drive and it didn't move...it was like the wheels were locked up. So I put it back in park, then drive again and it started moving, but with the sound. It was so loud I decided not to drive it out of the parking lot.

I took it to a service center down the street (didn't want to drive too far) and they could not properly diagnose the problem. They said either the transmission or transfer case. They priced me over $2,000 for a rebuilt transfer case, but are not entirely sure if that is the problem. They said when they put it in 4wd the noise got louder.

Has anyone had this problem? Or heard of this problem? The transmission has not been "slipping" and I have been using 4wd lately due to snow.

Any ideas?

(Sorry for the lengthy post...just want to include details that might help.)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:39 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC