Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Tranny fluid difference

Join Wrangler Forum Today


Thread: Tranny fluid difference Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-25-2011 04:11 PM
GroundHawg Personally...I'd keep the auto. My JK is automatic, and off-road, in traffic, or anything really..it makes life easier. My first car was a stick and that's how I learned. Every since I tried an auto I've never gone back.

Yeah they get expensive, but manuals can too. You can burn gears, slave cylinder...not just clutches.

Your TF automatic shouldn't be difficult to find. I bet most boneyards have at least 1. My buddy got a trans for his car at scrap heap for $300. Flushed it for $80. The install was 400ish. Not too bad considering a lot of REMAN trans' are like a grand without labor.

I'd stick with your auto. Call the junk dealers and see if any donors are around. They can be had cheap.

I have no clue how to do an auto-manual swap. Where did you get your Jeep? If it's private party sale, you could drop a call or stop by.

A trick I learned with vehicles, and this could apply to your situation..is stop by a trans shop and talk to one of the mechanics. He/she will have access to loads of information. They usually can be bribed for $20 or so on how to go about doing a job, and can provide papers, pics, even manuals and parts lists.

Just keep in mind your 4.2 may need replaced or need a major repair soon. She's probably seen a lot in her life. If you can get away with a relatively cheap reman trans, or scraped out trans I'd do it and save the money for the engine down the line.

Besides...autos really are better. Yeah manuals are fun, but autos are really where it's at IMO
02-24-2011 07:09 PM
beefmobile ok this is where i stand:

i have the fluid at a normal level. i got my shift cable all in order. now my problem is it is shifting really funny. Im starting to think that my shift valve body is either sticky or acting up. Does anybody have experience with a manual shift body?

Also, does anybody have any experience with a ratchet shifter? do you like it?
02-23-2011 06:28 AM
beefmobile Bump
02-21-2011 10:42 AM
beefmobile Well since it was fresh fluid, I couldn't tell where the fluid level was on the dipstick. It honestly looked like there wasnt anything there, barely a film of fluid to the touch. So I added a couple quarts and apparently its way over full now. It was literally spilling out and dripping on my driveway. I'm pretty freaking tired of this auto and am thinking about dropping a 5 speed in it. It was originally a 5 speed and still has the clutch pedal and everything. I guess one of the previous owners liked autos. Should I get a junk yard tranny? Which ones will bolt up to my 4.2? Will my transfer case work on a 5 speed? Will I need a new length driveshaft? I'm assuming I'll have to find a flywheel too? Sorry for all the questions but I've never gone from manual to auto back to manual lol...
02-21-2011 07:09 AM
GroundHawg I think Dexron II is what goes in those. Dex-III works too.

I might be wrong, but I remember that Dexron fiasco handful of years back. Chrysler said it was ok to use in place of ATF4...and everyone had transmission problems, that really took the idea and urban legend that Chrysler trannys are junk.

Have u ever flushed out the trans before this? I hope so. If this is the YJ in your pic we're talking about. If you don't flush auto's regularly like every 30-50k...they get b*tchy. I understand though u had no choice with the water and what not, but that might be what's up.

Um, I'd flush it again. Fill it with ATF4. I think those run on Dexron II or III, but if you've had luck with ATF4..roll it.

Personally...I think you have a clutch screwed up from the water. But start cheap. Hell, maybe it isn't full enough? Check that. Try the ATF4. then go from there.

Good luck.
02-20-2011 07:06 PM
herbie had a ford taurus come into the shop one time a few years back/she drove into a river/ I dropped the pan and ran a hose into a 5 gal pail of tranny fluid and i ran four pails of fluid thru it before it started coming out red again so three pan drops likely wont do it /as a side note the quick flush gigs dont do what some claim either--- edit to add if it feels like your dragging a brick outhouse behind you the torque convertor is likely damaged
02-19-2011 09:48 PM
183Beast Im no Automatic transmission expert, but I would guess that you have bigger problems.
02-19-2011 09:28 PM
beefmobile
Tranny fluid difference

I recently got in some deep holes and my tranny filled up with trail water. So of course I ended up with rosey pink tranny fluid. After I pulled the pan 3 times with no luck getting it back to a normal color, I had one of the local 4x4 shops do a complete flush. I was under the assumption that the TF999 trannies took ATF+4 which is what I've always used for it. But when I asked the guy what he put in it, he said dextron. I figured he knew what he was doing and i didn't think much of it. Well i drove around town a little and the tranny is slipping. I can still drive, stop, reverse, etc but it's definitely not putting all the power from the motor to the wheels. If i mash the pedal down when i take off from a stop sign, i have the acceleration of a damn bicycle. And when I dipped offroad for a minute to see how bad it was, I went up to a steep dirt mound and as soon as I started going up it (slowly, in 4hi), it just kinda kept slipping. Normally, I would just lose traction and spin the tires, but the motor just rev'd and I didn't go anywhere. I put it in 4lo and went right over the hill, but it concerned me.

Could using dex/merc really make that big of a difference from ATF+4? Or do I have bigger problems on my hands?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC