Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Squeak Squeak Squeak

Join Wrangler Forum Today


Thread: Squeak Squeak Squeak Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-22-2011 12:12 AM
Mikey51 Will do Jerry! Thanx
02-21-2011 07:51 PM
Jerry Bransford Check the brake shield, it might be bent and rubbing against the rotor. It is only made out of sheet metal so it's not all that hard to bend so it rubs the rotor and squeaks like crazy. It happened to me and I was getting frantic after a while of checking the usual suspects until I happened to notice the bent brake shield.
02-21-2011 06:31 PM
herbie u joint
02-21-2011 03:47 PM
AzTJ Yes, thats what I meant.
02-21-2011 03:44 PM
Mikey51
Quote:
Originally Posted by AzTJ View Post
Got to be an axle bearing if it's not making the noise with weight on it.
Thanks AzTJ...I think you meant NO weight! and I think you are right! I was hoping for dirty brakes LOL
02-21-2011 03:39 PM
AzTJ Got to be an axle bearing if it's not making the noise with weight on it.
02-21-2011 03:30 PM
Mikey51
Squeak Squeak Squeak

I just found this forum! Good to be here!
i have developed a squeak that is consistent with tire rotation. At slow speed appears to be left rear. Pulled and cleaned thew brakes... squeak squeak.. Jacked up to take load off and ran in gear..NO squeak! There is a double cardan DS , but has been in over a year. my last though is axle bearing. Can i get some of your thoughts? 06 rubi, 33" KMII OME lift, 1" body lift.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC