Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Rough Country 4" lift problem

Join Wrangler Forum Today


Thread: Rough Country 4" lift problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-25-2007 07:31 PM
02Prove
Quote:
Originally Posted by AzTJ View Post
I'm sure the installers fubard it somehow.
x2

I've heard bad things about letting some 4WD shops install your stuff. I would call in favors and try to get help doing it yourself. If you have a Jeep club in your area I would post up asking for help. Most Jeepers will be glad to for free beer and pizza.
07-25-2007 06:56 PM
AzTJ I'm sure the installers fubard it somehow.
07-25-2007 06:22 PM
"W4MAC" Your making me nervous, thats the kit I just ordered.
07-25-2007 05:21 PM
4point How bout a pic of what your looking at. I have a RC 4" kit also.
07-25-2007 04:57 PM
Scout Did they use the correct bolts?
07-25-2007 04:50 PM
tj4tnt They are the rough country arms.
07-25-2007 04:47 PM
AzTJ Are they the stock arm or RoughCountry ones? I'd take the arms off and inspect the bushings. They might have torn and need replacing.
07-25-2007 04:37 PM
tj4tnt
Rough Country 4" lift problem

I had a local 4x4 shop install a 4" rough country lift on an '02 sahara 4.0L. Approx 2000 miles later the lower suspension arms on all for wheels are slipping at the mounting bolts. They are torqued properly and greased. I am afraid the bolts sliding back and forth will slot the holes on the mounting brackets or the bolts will fail.
Has anyone else encountered this problem and what are some ideas on how to correct the issue.

Tom

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC