Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Computer out on 97 ??

Join Wrangler Forum Today


Thread: Computer out on 97 ?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-03-2011 09:41 AM
jgorm Check the fuel pressure.
03-02-2011 06:19 PM
dantheman2005
97 jeep wrangler 4cl 2.5L

hi Knox, did you fix your Jeep? I got the same exact problem. It is now dead and I change everything but the computer. Did you put a new computer? did it fix your problem. Please let me know how you fix it...
Thanks
Dan
04-07-2010 09:34 PM
knox new coil did nothing. I added a 4 gauge ground from battery to bell housing, and 14 gauge from battery to computer casing. Also no change!!
04-07-2010 04:14 PM
knox I am checking every wire that I can see/reach. I am also putting a new coil on tonight because I have had several people tell me to try that. 25 bucks is easier to find that 375 for computer.

I agree that I dont personally think it is the pcm but the mechanic is a friend of mine and not making any money off me so I dont think he is just trying to stick it to me
04-05-2010 12:42 AM
AKWrangler You may have already checked this but it's worth asking. did you check all of your wires to make sure none of them are broken or being grounded out? I had an o2 sensor go on me and replaced it but it still kept throwing the check engine light. I went back and inspected the wires and found a broken wire. works good now.
04-04-2010 09:37 PM
Jerry Bransford It doesn't sound like a bad PCM to me, and it's true that the PCM changes every year. The PCM has to match the model year, engine, and transmission type. It almost sounds like the distributor is out of time with the engine but I'm not an engine expert.
04-04-2010 08:20 PM
kdukes4 i dunno if its true or not but for my '97, i got a new(refurbished) pcm for $175 w/lifetime warranty. pm and i can send you the link sometime, i don't have it here with me, sorry. resolved my issues though got it off of fleabay though.
04-04-2010 07:41 PM
AzTJ If the computer was "dead" the Jeep wouldn't be able to start. I'd look into fuel issues. It sounds like the engine isn't getting enough of it for the higher RPM's and is cutting out.
04-04-2010 05:15 PM
knox I need some help here folks. I am OUT of ideas on making this thing run!!

There doesnt happen to be anybody in the greater Knoxville area with a 4cyl auto that would let me plug their computer to my Wrangler to see if it is a computer problem? I thought not.

I need some ideas, or a computer (maybe)
04-03-2010 09:15 PM
knox
Computer out on 97 ??

I am still trying to get my 4cyl/auto TJ to run. It has a hard dead miss at 3000 rpm and will not rev past that point in any gear, park or neutral. Codes say MAP and O2 and I've replaced MAP sensor, coolant temp sensor, o2 sensor, cam sensor, crank sensor, new plugs. Ive checked compresson, throttle pos sensor, and run it with no exhaust with no change in the miss. Codes still say the same thing.

Heres the question. does it sound like a bad computer? Is there any way to check the computer it without replacing it. And Ive been told that the 97 has a computer that is ONLY used on a 97. Is this true?

Any other ideas would be GREATLY appreciated.

Thanks for any help in advance!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC