Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > I noticed rough idle after lift.

Join Wrangler Forum Today


Thread: I noticed rough idle after lift. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-31-2007 01:13 AM
bpowa I tossed the old plugs there are no vacuum leaks.

its not that bad just think it should not vibrate at all for a 05. I might try buying some ngk's.
07-31-2007 01:04 AM
Triple88a vacume leak on the manifold or the plugs.. throw the old plugs back in and hope for the best..
07-31-2007 12:48 AM
bpowa
Quote:
Originally Posted by Triple88a View Post
when you stop.. shift to neutral.. does it still shake or does it ease up?
I did that its the same thing.. like I said the idle says pretty constant..

I figures the lift might cause the yoke to stress a bit.. I was wrong.. I tried the transfer case idea.. still does it..

I took out ngk plugs.. I am always a big fan of them.. but when I went to the parts place they had none for the jeep.... I figure mopar uses champions..

Why did chrysler switched to ngk?
I checked 3 places and no one sells the plugs.. dont want to go to ythe dealer and pay tripple the price for them.
07-30-2007 11:57 PM
Triple88a ^ 2x
07-30-2007 11:54 PM
JeepCrawler98 If you changed your plugs I would be first to blame that for a rougher idle than a spacer lift. That t'case drop shouldn't do anything unless your vibes are with the driveshaft turning.
07-30-2007 11:51 PM
Triple88a when you stop.. shift to neutral.. does it still shake or does it ease up?
07-30-2007 11:41 PM
bpowa I found this link..

http://www.4x4xplor.com/t-casedrop.html

I might try a washer or 2. I doubt its thenew plugs I changed.. I used champion platinums.. gapped all the same .33
07-30-2007 11:35 PM
JeepCrawler98 The only time you'd have to drop the t-case is if you'd get very high speed vibrations as you're driving (this is usually right after taking off from a stop); this would be because the angle on the driveshaft is too steep as a result of the lift.

As far as the rough idle - unless something got knocked loose or screwed up during the install I really don't see how the two could be related. The only thing I could think of is perhaps some stress in the bushings on the stock components? It's a very long shot - but try loosening all the bolts on the suspension (don't remove just loosen) then retightening them to relieve any stress.

Did you put new shocks in as well? Perhaps these are stiffer and don't allow the frame to shift just that teeny bit as the engine 'bumps around' a little bit at idle.

Your motor mounts/tranny mounts should be unaffected as you did not drop the transfer case.
07-30-2007 11:26 PM
bpowa it was a 2'' bb.. 05 x 4.0liter automatic.. no I did not have to drop the transfer case.. The idle is not actually rough.. it just feels as if the mounts are tweaked somehow..

make the rig vibrate at idle.. the rpm is in a still position.

do I have to drop the t-case? if so why?
07-30-2007 11:23 PM
JeepCrawler98 What type of lift?
07-30-2007 11:13 PM
Triple88a What kid of lift did you do? Manual tranny vs automatic? Did you drop transfer case?

Maybe a vacume leak or something? Check around the manifold for some rubber piping that may have came off loose since from memory thats where you have to shuv in a wrench to unscrew the shocks. Give us some more info on your rig..
07-30-2007 11:08 PM
bpowa
I noticed rough idle after lift.

well the idle is not jumping around or anything. I just knowticed when it is at a stop the jeep shakes more.. like weak motor mounts etc..

what can it be after a lift?

thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC