Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Trouble with stabilizer install

Join Wrangler Forum Today


Thread: Trouble with stabilizer install Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-15-2011 06:53 PM
oIIIIIIo I had to drill the bolt off...it was a PITA!
03-15-2011 03:58 PM
Cons_Table
Quote:
Originally Posted by Atthehop View Post
I used a tie rod puller to get mine off.
I tried this one...the two tie rod pullers we had were the wrong size...one was too big, the other was too small...figures, right?
03-15-2011 03:49 PM
KCrisp I tried all of the above and more, broke some Harbor Freight Tool tools, and eventually cut it off with a saw and drilled it out. I REALLY hope for your sake that some of the easier solutions do the trick.
03-15-2011 01:43 PM
Atthehop I used a tie rod puller to get mine off.
03-15-2011 01:42 PM
Orngtruk Heat it up with a propane torch
03-15-2011 01:05 PM
Cons_Table
Quote:
Originally Posted by ellman605 View Post
Thank you. I've given up for the day but ill give that a shot on Thursday.
You may continue spraying it with your pentrant over the next few days a few times a day to see if that helps loosen it up...
03-15-2011 01:02 PM
ellman605
Quote:
Originally Posted by Cons_Table
I assume you are talking about the bolt going through the drag link? Soak it in a good penetrant like pb blaster. Take a few firm hits to the side of it and that should help break it loose. Last time I did mine, I had to soak it, smack it, soak it, and smack it before it started coming out.
Thank you. I've given up for the day but ill give that a shot on Thursday.
03-15-2011 12:18 PM
Cons_Table I assume you are talking about the bolt going through the drag link? Soak it in a good penetrant like pb blaster. Take a few firm hits to the side of it and that should help break it loose. Last time I did mine, I had to soak it, smack it, soak it, and smack it before it started coming out.
03-15-2011 12:10 PM
ellman605
Trouble with stabilizer install

I'm having an issue getting the castillated (spelling? I forget) bolt off. The one with the cotter pin(I took it out). I doused it in wd40 and used all my strength, but couldn't get it off. Any tips?

Also, the bar that its attached to (looks like the one used to steer the tires) is supposed to move up and down a bit...right?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC