Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Oil change?

Join Wrangler Forum Today


Thread: Oil change? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2011 01:01 PM
Bazzer Oh, I didn't know Wranglers did this. I just changed my oil last weekend and never did the reset. Out of interest I may wait until it comes on so I know how conservative I have been with a timely oil change.
04-03-2011 11:50 PM
MCAD135 Yeah they forget to do that some times. Easy fix if ya know what to do
04-03-2011 11:44 PM
4 Jeep Family To reset it turn the key to on, don't start. Slowly depress the accelerator pedal all the way down 3 times, within 10 seconds. try to use at least eight seconds.
04-03-2011 11:40 PM
4 Jeep Family It sounds like the dealer didn't reset the oil mileage reminder.
04-03-2011 10:37 PM
JkJared
Oil change?

So I just bought my 2007 wrangler 4dr sahara from the dealer. It had fresh oil as I checked upon purchasing. I then took a trip 400 miles to a my mother in laws when ding the oil change message came up.. Why would this be happening when it's clearly fresh oil? The worst part about this whole situation is it keeps chiming every like 30 seconds while I'm driving even when I dismiss the message it keeps dinging... I'm thinking maybe because it hasn't had a good drive down the highway in a while? Someone please help me out thanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC