Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum > Sudden acceleration between shifting of gears.

Join Wrangler Forum Today


Thread: Sudden acceleration between shifting of gears. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-03-2011 08:00 PM
Peepers Welcome. It could be a vacuum leak in the idle control.
05-03-2011 07:51 PM
AzTJ Tell us what model Jeep it is, then we can put this in the right section for better answers.
05-03-2011 05:23 PM
yomondo Hello and welcome to the forum. You didn't mention what type of Jeep you have (JK/TJ/YJ/CJ), but try posting your question in one of the Wrangler Model Tech Forums . You'll reach a wider and more appropriate audience there. Hopefully someone will be able to help you. Good luck.
05-03-2011 03:03 PM
DukeStKing
Sudden acceleration between shifting of gears.

Hello, everyone. I'm having a problem that started out occasionally, but is happening more often. Maybe someone can help me out. Seems that while driving for a bit, or between the shifting of gears, (when I depress the clutch) the engine starts to rev out of control on it's own. I usually have to move to neutral, and shift again to remedy this. Is it my clutch going bad? Kind of new to this.

Thanks for your help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC