Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Harmonic Balancer question.

Join Wrangler Forum Today


Thread: Harmonic Balancer question. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-18-2011 08:27 PM
kboles89 x2
05-18-2011 05:47 PM
RPM Do not trust the timing mark on the ballincer!! Pull #1 plug find compression stroke, use a long thin screw driver to find TDC. spin the engine back and forth and get it as close to top as possible.. is the ballincer on TDC ?? If not the rubber in the ballincer melted and sliped.. the truck runs .. crank sensor is gettin the timing ...
05-18-2011 02:59 PM
sjkorenek It points to zero on the timing scale though on TDC. Always. Are you saying it can slip with the motor running and go back to where it belongs?? Also am not understanding why the crank pos sensor will not line up on the skips in the teeth on the flywheel. This is making no sense at all.
05-18-2011 02:44 PM
kboles89 I've seen alot of gm balancers go bad because the rubber in them allows them to turn. Seeing that the 2.5 was originally produced by gm I'd put a new one on there. Give that a try, let us know what your results were.
05-18-2011 02:06 PM
sjkorenek
Harmonic Balancer question.

Rebuilt 2.5 from NAPA. Just installed,, runs smooth without harmonic balancer on. Of course ran briefly. Idles rough with it on. Balancer seems to be in good shape, however , holes have been drilled (4 eighth inch holes) on one side. Could this cause a rough idle?? Plus seems that flywheel timing marks are off for the crankshaft sensor. Please help if anyone can. Thanks.....

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC