Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Transfer case problem

Join Wrangler Forum Today


Thread: Transfer case problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-24-2011 09:41 AM
Jerry Bransford I'd have it looked at if you don't want to open up the transfer case yourself. If the chain is stretched, and they can eventually stretch, it needs to be replaced.
05-23-2011 08:25 PM
TyJeep97 should i have that looked at or is it alright?
05-23-2011 07:48 PM
Jerry Bransford It's hard to diagnose sounds but I'll just toss one suggestion out that perhaps your transfer case's chain is getting loose and is occasionally slapping the side of the transfer case.
05-23-2011 06:15 PM
TyJeep97
Transfer case problem

I have a rattle coming from the front of the transfer case it sounds like. I took the front driveshaft off because i thought it was a U joint and the noise stopped but without the driveshaft in the transfer case does not spin either so I think it is still the problem. I checked all the U joints on the shaft and they all seemed to be in good working order. I was searching on the forums here about the same problem but everyone elses seemed to be affected by the speed they were going or the gear they were in or one of thoes variables where mine happens all the time. It is not an very loud rattle but it is noticeable most the time while driving. When I let off the gas completely after going faster at like 45 or more there is a slight vibration almost like the U joint is going bad (i had that happen in the rear before) but other than that the jeep runs smooth. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC