Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuel pump?

Join Wrangler Forum Today


Thread: Fuel pump? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-29-2011 12:33 AM
divernaz So I checked the fuel lines from the tank and they were on the proper way. The new fuel pump hums when I turn on the ignition. The fuel filter is pointed the right way. I've tried turning the ignition several times to prime it being fuel injected. Its still not turning over. When I put a little gas in the intake it turns over for a brief second and shuts off. I tested the pressure on the fuel rail and I'm not getting anything. I'm way confused. Do I replace the fuel regulator? Clean the fuel injectors? It's a 1992 wrangler with 65k miles on it. Really not sure what to check or do next.
05-27-2011 10:15 AM
Buddha I had the same issue after replacing my fuel pump and it turned out that I had accidentally swapped the fuel lines coming from the tank. I had the fuel supply line connected to the fuel return line and vice versa. I ended up being able to swap them out without re-removing the tank by accessing them at the front of the tank on the drivers side and just swapping them around. Started right up...
05-26-2011 06:19 PM
divernaz oh okay. I gotcha. When I replaced the fuel pump I replaced that with a new one as well. I just don't understand why I'm not getting any fuel pressure to the fuel rail.
05-26-2011 03:01 PM
Garyk There is a fuel pick-up in the tank, connected to the pump, usually covered with a mesh to keep crud out....if its loose or bad that could be your problem.
05-25-2011 08:14 PM
divernaz @ Garyk, I'm sorry but what do you mean by pickup in the tank?
05-25-2011 07:51 PM
Garyk Check the regulator.
How was the pickup in the tank?
05-25-2011 07:27 PM
divernaz I'm not getting any pressure at the rail, although when I press the pressure release button on my gauge I do get some fuel squirting out.
05-25-2011 07:23 PM
stykthyn Have you checked pressure at the rail?
05-25-2011 06:46 PM
divernaz
Fuel pump?

Got a 92 Jeep 4.0 and my brother was driving it till it ran out of gas in front of my house. I put more gas in and it wouldn't start back up. Just figured it was the fuel pump so I replaced the fuel pump and filter and it still wouldn't start up. I checked the the pressure on the fuel rail and I wasn't getting any pressure at all? I can hear the fuel pump hum, just not sure where to go from here. Thanks for all your help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:15 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC