Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Crunchy Clutch?

Join Wrangler Forum Today


Thread: Crunchy Clutch? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-31-2011 02:53 PM
dan188 I had the exact same sound from my bell housing a few months ago on my 98. I ended up replacing the master cylinder, slave cylinder, and all the clutch parts (pressure plate, throw-out bearing, disk, pilot bearing, etc.). It turned out that my pressure plate springs were shot (which was the clicking sound), and one tab was almost completely broken. I don't think I needed to replace the master cylinder, but I thought I would do it since it was old and the fluid looked horrible. Now that everything is replaced it runs great. No noises and smooth shifts.
05-31-2011 10:38 AM
Wisshockey99 My jeep has recently began doing that as well... I noticed it last week and when i took my jeep in to be checked, they told me my clutch was about to go out and my fly wheel was pretty shot to... 1500 to replace both and it still makes a clicking noise... Now it may just be a jeep getting old thing because i have a 1997 but i doubt it, i do drive through mud alot (at school because w ehave a narrow exit that gets jammed everyday at the end of school so i go accross the lawn sometimes) so maybe mud got in my housing but im intereested to see what people say
05-30-2011 05:34 PM
thedodson If it's coming from around the bell housing it could be a throw out bearing goin bad. I would assume it would make alot more raquet than that tho.
05-30-2011 05:24 PM
C.L. Negatory. Up here in north Jersey, anything remotely fun like that is illegal. I was reading in another thread that one could clean the flywheel surface by blasting brake cleaner in through the "inspection holes", but i didn't see any inspection holes while i was under there this morning. They don't mean the 1/8" gap between the bell housing and the plate on the front of it, do they?
05-30-2011 04:58 PM
Jerry Bransford Have you ever driven your Jeep into deep mud or deep muddy water and stepped down on the clutch pedal while you were there?
05-30-2011 02:12 PM
C.L. Ok so i went poking around. The Jeep clutch is hydraulic starting much closer to the pedal than i thought it was. I had assumed mechanical until somewhere closer to the transmission, but it looks like the pedal attaches directly to a piston (Master cylinder?) through the firewall. The ticking sounds like it is coming from inside the bell housing, or the black cylinder (slave cylinder?) attached to it. Hard to tell with me trying to hang my head under the Jeep and press the pedal with my hand at the same time...

It feels as though the resistance is coming from something grabbing the pushrod going through the firewall, but that's directly into a sealed cylinder, and i see nothing binding/rubbing before there. I have noticed that the resistance and slight scraping noise are both more pronounced if i press the clutch in very slowly. It feels almost normal if i press it in quickly. Looks like i can't really lube any mechanical parts since it's hydraulic starting immediately after the pedal.

Ideas?
05-29-2011 08:14 PM
C.L.
Crunchy Clutch?

For the past month or so i had noticed a "tick" or two when depressing/releasing the clutch pedal. Started so quiet i could only hear it with the engine off, and it was not adding resistance to the pedal. Today i noticed it's gotten louder to the point where i can hear a couple ticks with the engine running, and the pedal seems a bit restricted. Takes a little more effort to push down, and feels like it's fighting some resistance on the way back up. With the engine off i can hear a bit of a scrape, too. Since the restriction/scraping feels mechanical, i'm hoping it's just a bearing wearing out or misaligned.

I'm going to poke around tomorrow and see if i can find anything that looks unusual, but i figured i'd check in with the gurus here first. I've never pulled anything off a hydraulic clutch before, anything i should stay away from to avoid a face full of brake fluid?

This is an '04 6cyl, with the NV3550 transmission.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC