Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > fuel issues

Join Wrangler Forum Today


Thread: fuel issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-31-2011 10:41 AM
Garyk Did you replace the fuel pump with the same model? Some electric fuel pumps will not "pick-up", how about the screen at the pickup, is it clean? Make sure your gas cap is good.
05-31-2011 02:24 AM
Undead-89 Yeah, vapor lock is an engine issue not a tank issue. You may have vent hose issue in the tank which could be why you have to hold the pump half out, or an obstruction in the fill hose.

Neither of these would cause your issue. Unless for some stranger reason you tank is hermetically sealed and does not allow any air at all in the tank in which case you fuel pump would be fighting the vacuum created by removing the gas. Since gas caps are vented, this seems unlikely.
05-30-2011 10:08 PM
444 That's not what vapor lock is. And having to refuel at a slower speed is not what's causing your problem. Sounds more to me like you have an obstruction somewhere in your fuel system. Your electric pump should put out a pretty healthy fuel flow when you run it into a bucket.
05-30-2011 09:58 PM
jyounk83 The jeep is in fact a 4.2L 258, the electric fuel pump was an alteration that was put on prior to my purchase but then needed replaced in January. I will disconnect my lines running into my tank and blow them out to see if they are clogged...very good possibility.

As for the wiring, right now I have my pump with direct wiring to my battery (not permanent) to make certain that there is no mix up with the wiring. I assume that the lines are hooked up correctly on the fuel pump (inflow and outflow are the only two and the arrow on pump is in the right direction). There is a return line coming out of my fuel filter and looks to be hooked up correctly.

I do want to note that I do have what I think is a vapor lock? When I pump fuel into my vehicle I have to hold the pump half way (always have from purchase date) to fill it up and I am not sure if perhaps that is causing an issue? But I never had problems with my fuel until recently.

Will double check all the info you guys have sent me and check those lines to the tank. Thank You for the tips and I hope she will be out scooting soon...this nice weather is giving me the itch!
05-30-2011 01:58 PM
Undead-89 I assume it is a 4 cylinder TBI if you have an electric fuel pump or it is an after market alteration. But you are saying carb which should be a 4.2 with a mechanical pump.

I agree with the above you might have something in the tank that is clogging the feed line and floats away when you stop pumping, only to get sucked back in after a bit.

The other things to look at are:
Wiring connections, especially if this is aftermarket and just recently replaced)
Make sure the hoses are hooked up correctly. I think with an electric pump you have a feed tube and a return line. The return line should feed back whatever fuel isn't used by the engine to the tank so you fuel pump isn't over working.
05-30-2011 01:14 PM
tracy blow the line into the tank-could be trash,,,,
05-30-2011 11:52 AM
jyounk83 Fuel filter is new. the trouble lies somewhere before my electric fuel pump I believe.
05-30-2011 06:00 AM
RLaFitte What about the fuel filter? It sounds like it's clogged up to me. Replacement is quick, easy and inexpensive. Good luck!
05-29-2011 09:54 PM
jyounk83
fuel issues

I own a 1987 YJ and I am experience fuel pressure problems. When I disconnect my fuel line going into my carb I am not pushing out fuel all the time. I disconnected my fuel pump and put the hose into a can of fuel to see if indeed it was pumping...it did. When I hooked the lines back up and turned my key on I could hear the fuel being pumped into my into my fuel filter which is located just prior to my carb. When I try to start my jeep it turns over and runs for a very short time then dies. I have noticed that when I let it sit for a few moments it seems to fix itself momentarily by allowing the fuel to flow into the carb until I start it again and the fuel is burned up. Also, the fuel pump has just been recently replaced. I am not sure if there is a pressure problem or not since it seems like when I disconnect the lines or let it sit fuel will begin to flow once again. I am unsure where I should go from here but some help would be fantastic!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:34 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC