Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > All gauges stopped working..help needed

Join Wrangler Forum Today


Thread: All gauges stopped working..help needed Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-07-2011 02:06 PM
A1bertmarkovski Thats good it was something tiny...mine would go out every once in a while and i would just pound the dash till they came back on haha
06-07-2011 12:50 PM
Sandy Feet Thanks all! It was just a stupid little fuse that I missed under the hood. Problem solved.
06-07-2011 01:55 AM
MP92 Did you try a gauge test? If not, hold your tack and turn key to last click before start and let go of tack. Isl if this will work but good luck
06-07-2011 01:39 AM
legman68 Hmm, I'm not sure on the stereo, but the instrument cluster is a common problem. You have to remove the shield under the steering wheel, then a few more screws, and the whole cluster will pop out, just a little pull. It's one big connector in the back, put some of that electrical grease, pop it back in, and you should be good. Oh, and don't forget to check the fuses!
06-06-2011 05:36 PM
Sandy Feet
All gauges stopped working..help needed

Well, I just bought this Jeep, 97 TJ. I have disconnected an amp that wasnt working but thats about it. Today all of the gauges on the dash including the stereo is out. Nothing will come on. Any suggestions?? Thanks for any advice.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC