Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > '07 Rubicon rear locker wont lock

Join Wrangler Forum Today


Thread: '07 Rubicon rear locker wont lock Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-10-2011 05:58 AM
bigf350sd Thanks everybody, I'll try some if this stuff again, see what happens. It's always worked the first time though, so my bet is the coil, as mentioned above, not working.
06-09-2011 10:13 AM
Hilldweller Sometimes they won't mesh mechanically; try driving in a circle at 3 mph or slower. Try going in reverse for a few feet too.
06-09-2011 09:00 AM
InfernoGirl
Quote:
Originally Posted by daggo66 View Post
Sorry to hear about your rear end Linda. I hope it gets fixed soon.
Thanks Tom I always appreciate a guy who's concerned about my rear end......
06-09-2011 08:53 AM
bigf350sd I'm gonna check out all the fuses & connections this evening, if I can. May even get it up in the air & pop the cover and stick it in 4 low and have someone hit the locker button and see what I see.
06-09-2011 07:03 AM
daggo66
Quote:
Originally Posted by InfernoGirl View Post
Locked and wouldn't disengage. Had to replace the entire unit. It was expensive... will get the Jeep in for the rears soon I hope, no clue how much that one will be.
Sorry to hear about your rear end Linda. I hope it gets fixed soon.
06-09-2011 12:02 AM
rics1997 They are electric engaged so there could be numerous electrical reasons for failure in the circuit. The coil could be bad or the wiring could have an issue. If it was the locking pins in the locker itself, you would probably hear a grinding noise in the diff and since there has been no issues there then I would bet it is in the electrical system. Might be wrong but since it seems to drive fine it sounds like the coil is not engaging the locking pins
06-08-2011 11:58 PM
jdhallissey If you broke one or both please please please do not put in a stock unit. IF your are already spending the money get ARB's and don't look back. I blew up my rear 44 locker this past week in moab and I am not even thinking of going with another stock unit. No point unless somebody basically gives me one for free.
06-08-2011 11:38 PM
bigf350sd Hmm, I'm curious as to what goes out in them to make them quit working, and why it isn't repairable, in your case anyway they weren't. I'll have to see if I can find anything explaining how they work on google.
06-08-2011 08:32 PM
InfernoGirl Locked and wouldn't disengage. Had to replace the entire unit. It was expensive... will get the Jeep in for the rears soon I hope, no clue how much that one will be.
06-08-2011 08:18 PM
bigf350sd When you say they crapped out, what went wrong with them? Were they repairable, or did you replace the whole thing?
06-08-2011 07:49 PM
InfernoGirl Our front ones crapped out last Dec on our '07, now the rear won't stay locked.... It's not a cheap replacement either. I forget what the front was to replace (selective amnesia) will find out soon I guess how much it is to replace the rear...
06-08-2011 07:29 PM
bigf350sd
'07 Rubicon rear locker wont lock

Hi. Recently I put front and rear ARB differential covers on my '07 Rubicon Unlimited. I'm not gonna swear to it, but I THOUGHT that I had used the lockers since I installed the covers, and had no problems, but at any rate, today I went playing around, and when I engaged the lockers, the light for the rear wouldn't quit flashing. The front would lock up fine, light stay solid, and I know it was locked, I could barely turn, but the rear never quit flashing. The owners manual says the light will flash until the lockers are completely locked or unlocked. I turned them both off, and then tried the rear several different times, and the light never quit flashing. Of course, I had everything as it should be to use the lockers, 4 low, under 10 MPH, etc...etc... ARB's site says that their covers do not affect the action of the lockers, so it's possible that the covers are not the problem, but who knows? Anybody else had any problems/experience with one of the lockers not engaging on their JK, or have any ideas or suggestions? Thanks.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC