Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > UConnect In the 2011 Wrangler

Join Wrangler Forum Today


Thread: UConnect In the 2011 Wrangler Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-03-2011 09:47 AM
xsdbs well there's 2 ways to think about this:
1) the install is not difficult if you have some tools and mechanical abilities. I can send you the install guide for you to look at and see if you can handle it. Just PM me with an email address and I'll send it to you.
2) you could purchase the kit online, have an accessory shop do the install for you, (probably around $100 for the install).
After the kit is installed then you will need to go to the dealer to have them flash the vehicle so that it knows you now have Uconnect. They'll probably charge you 1/2 labor or even talk to your sales person to see if he / she can pull a favor for you with the service dept.
Also, you will want to decide if you are going to use an IPhone or IPod with this system, the reason is because the Mopar kit dooes not come with the USB cable PN 82212160, it is sold as an optional cable. You will want to make sure that you are getting a High Speed CAN BUS system also. Your vehicle has a High Speed BUS network and a Low Speed system will cause you issues with the vehicle as well as not work.
You will also want to ask the people who you're buying the kit from what the PN is on the main module, you will ideally want a module that tends in "AK" because it has the most current SW in it. If it ends in ""AG" then let me know and I can get you the update file, it's easy to download and perform.
Hope this all helps you out. If you have any questions, just ask.





Quote:
Originally Posted by durkine1 View Post
I just bought a 2011 wrangler and now I am thinking of getting the u connect setup in my jeep. I have the media center 130 with sat radio. The deck does have the buttons for unconnect it's just not setup. Has anyone had the unconnect installed in the San Diego area? I've called multiple dealers and the price is all over the place from $550-$700. I saw the mopar kit online but was wondering if doing the install yourself is a pain. Any feedback on what I should pay or install myself would be appreciated.
12-03-2011 08:42 AM
durkine1 I just bought a 2011 wrangler and now I am thinking of getting the u connect setup in my jeep. I have the media center 130 with sat radio. The deck does have the buttons for unconnect it's just not setup. Has anyone had the unconnect installed in the San Diego area? I've called multiple dealers and the price is all over the place from $550-$700. I saw the mopar kit online but was wondering if doing the install yourself is a pain. Any feedback on what I should pay or install myself would be appreciated.
12-02-2011 03:04 PM
xsdbs That's because you have the most current module in the vehicle that includes the update.



Quote:
Originally Posted by Jkujon View Post
My iPhone 4 works great in my 12. No problems at all.
12-02-2011 08:25 AM
Jkujon My iPhone 4 works great in my 12. No problems at all.
12-02-2011 08:09 AM
xsdbs a few things here,
1) no, the IPhone does not work in every other car.There are many that it doesn't work in. If you have read more posts about this issue, you would realize that the SW for the 2011 vehicles was written in late 2009 and early 2010. At that time of testing Apple had SW version 4.0 & 4.1. The Iphone passed testing with that SW version. Later in 2010 (around July - August) Apple came out with their 4.2 and the vehicles had already started being built. It then takes time for the vehicles to get into the public hands and for issues to start showing up. It takes some time before it really gets to the Engineers to find out what the issue is.
So tell me , if the IPhone passed testing when the Uconnect SW was wrote, but then had issues after Apple updates were performed, who caused the problem? Do you really think that there is a way to know what phone manufacturers are planning in 6 month to a year later? Apple is not the only company that has caused issues. There have been updates from Samsung, HTC, LG and others that have caused a passing phone to no fail. Why do you think that if a phone (device) company caused an issue with a phone that has passed testing that it is the car kits responsibility to fix what the device company broke? During the testing of a device, if it fails there is information on the failure sent to both - Uconnect Engineers and the deice Engineers where at that time they work together to find out what is causing the issue. If the device company doesn't work with the Uconnect Engineers to fix the issue, then the device is not added to the list.
Heck, even when Microsoft and other companies comes out with an update, issues shows up. What happens? That company comes out with a new update to fix the problem.
2) If the device companies would get with Uconnect to validate their new update before they released it, the device company (as well as Uconnect) would know about issues and work on a fix before releasing it to the public. But they don't, so when the surprise comes that "hey, my phone used to work great before I did the update and now it doesn't work right at all". Wow, who caused the problem? Who should fix the problem?
3) I am sure that by your anger about your situation,that you haven't read enough posts to know that there has been a Uconnect update (that the Uconnect Engineers wrote to HELP the customers with devices from manufactures who wouldn't help). The Chrysler TSB is 08-036-11, which has been released since June 29, 2011 and has been revised by 08-036-11A which was released on Oct 26, 2011.
This TSB will take care of your issues (phone issues).
4) I would like to know who keeps telling you "too bad, go on the internet and find a phone that does work"? Who have you been "escalating this issue" with? Is it a dealership? If so what dealership? Is it the customer care group? If so do you have the name & phone number of that person?





Quote:
Originally Posted by angel2603 View Post
I couldn't agree more! Why would anybody think the iPhone should be fixed / changed?! The iPhone works just fine with EVERY OTHER CAR! Not only that, but it says even in the instruction manual to connect your iPod device so you can stream via Bluetooth or plug it in - NEITHER WORKS!!!! I am SOOO disgusted with Jeep / Chrysler at this point as they have absolutely no interest in doing anything about it. I keep escalating the issue to the next level, but they keep telling me "too bad, just go on the internet and find a phone that works". Are they insane? Neither the dealer nor the Chrysler direct care. The iPhone is the most popular phone in the world and this is a BRAND NEW CAR...not some 5 year-old piece of junk... Had I known this, I would have returned my 2011 Jeep Wrangler right away - I just thought it was one flawed radio and I was sure they'd fix it, but they won't!
12-01-2011 03:57 PM
angel2603
Quote:
Originally Posted by vismich View Post
Why would you think it would be Apple that needs to fix this problem?

To me, as technology progresses, the company that is making the radio needs to keep up. Apple could care less if people can use there phone on a Jeep...It's not Apple that claims they work...
I couldn't agree more! Why would anybody think the iPhone should be fixed / changed?! The iPhone works just fine with EVERY OTHER CAR! Not only that, but it says even in the instruction manual to connect your iPod device so you can stream via Bluetooth or plug it in - NEITHER WORKS!!!! I am SOOO disgusted with Jeep / Chrysler at this point as they have absolutely no interest in doing anything about it. I keep escalating the issue to the next level, but they keep telling me "too bad, just go on the internet and find a phone that works". Are they insane? Neither the dealer nor the Chrysler direct care. The iPhone is the most popular phone in the world and this is a BRAND NEW CAR...not some 5 year-old piece of junk... Had I known this, I would have returned my 2011 Jeep Wrangler right away - I just thought it was one flawed radio and I was sure they'd fix it, but they won't!
10-06-2011 09:05 AM
xsdbs IN Reference to post # 94 above::


Ok, so Apple has provided a new set of updates:
4.2.10 for Verizon Iphone and
4.3.5 for ATT IPhone (3&4) as well as iPods.
With the Iphone there is a chance that you may experience 1 of 2 issues when plugging into the docking cable:
1) you may get an "error occurred" message,
or
2) you may get a long "reading" time frame that seems not to go away,
If you get these messages, you will also notice that on the phone will be another message "accessory device not supported by phone"
I have performed several different tests on the phones and found that this case seems to happen if you plug the cable into the phone when it is turned completely off.


So the “real world” case that this would happen is:
1)If a person has a phone that is paired to Uconnect, turns BT off to preserve the battery level,
2)Leaves the vehicle and does some activity where he / she will play the iPod during this activity,
3)Drains the battery down and the phone shuts off or they power off the phone to save some battery charge for calls before getting back to the car,
4)When they get back to the vehicle and plug the phone into the docking cable without having powered it up,
5)After the phone powers up a the “accessory not supported by Iphone” will pop up on the display,
6)If they immediately press the MEDIA button , select Aux Uconnect will show “Reading”, then “Error Occurred”, when the error box goes away the Aux screen shows 00:00 on the timer and the < > & ll buttons are light blue (inactive),

Steps to get past the “Error Occurred” message
1)Unplug the docking cable, power up the phone after the phone is powered up, plug in the docking cable, press the Media button, select “Aux”, Uconnect will Read then start playing,
2)If not done as described in step #1, I have had to unplug up to 4 times before “Reading” was done and play started,

10-06-2011 09:01 AM
xsdbs OH, I got it now. I knew it was there for the 730 radio, I thought htere may have been something on the 430 radios. Thanks




Quote:
Originally Posted by CoRubisRock View Post
Here is the url: https://www.jeep.com//hostb/crossbrand/owners/en/

Then the very last option is "Free iPhone 4 Radio Upgrade (730N RER Radio only)"

It's for the 730N, but that seems to be one of the radios that people are buzzing about. I don't know if it will help anyone out there, but thought I'd point it out.
10-05-2011 04:50 PM
CoRubisRock
Quote:
Originally Posted by xsdbs View Post
I looked but didn't see this. Can you tell me where you found it? Did it say what the "patch" was for? Thanks
Here is the url: https://www.jeep.com//hostb/crossbrand/owners/en/

Then the very last option is "Free iPhone 4 Radio Upgrade (730N RER Radio only)"

It's for the 730N, but that seems to be one of the radios that people are buzzing about. I don't know if it will help anyone out there, but thought I'd point it out.
10-05-2011 09:03 AM
xsdbs I looked but didn't see this. Can you tell me where you found it? Did it say what the "patch" was for? Thanks

Quote:
Originally Posted by CoRubisRock View Post
Di you happen to notice that they have a new iPhone4 patch to download on the jeep owners site? I use my old iPhone 3GS plugged into the jack and it works like a charm. My husbands 4 works this way also. Plus, it doesn't loose any sound quality the way that (I've heard) bluetooth can. But, I have the media center 130, and I don't have the usb jack, the hard drive, or any of that stuff. Also, I haven't felt like paying the dealer to get the Uconnect installed, so I can't really speak to how well the bluetooth streaming actually works.
10-04-2011 01:25 PM
CoRubisRock Di you happen to notice that they have a new iPhone4 patch to download on the jeep owners site? I use my old iPhone 3GS plugged into the jack and it works like a charm. My husbands 4 works this way also. Plus, it doesn't loose any sound quality the way that (I've heard) bluetooth can. But, I have the media center 130, and I don't have the usb jack, the hard drive, or any of that stuff. Also, I haven't felt like paying the dealer to get the Uconnect installed, so I can't really speak to how well the bluetooth streaming actually works.
09-13-2011 08:23 PM
xsdbs Send me a PM with an email address and I will help you out. Also just so that I am clear, your vehicle is a 2011 wrangler? I ask because there have been several people that I have helped here with other chrysler vehicles.


Quote:
Originally Posted by Djstorm100 View Post
Looked at the links Amd those still have the screen. I'm referring to the radio that doesn't have the screen just the plain jane radio with uconnect. I'm not sure what file to get nor am I sure at how to install the update
09-13-2011 09:59 AM
Djstorm100
Quote:
Originally Posted by xsdbs View Post
Yes there is, you would use the same update file that I had mrjeep post on page 13, reply 387 of the link below.


http://www.wranglerforum.com/f33/201...-88954-19.html
Looked at the links Amd those still have the screen. I'm referring to the radio that doesn't have the screen just the plain jane radio with uconnect. I'm not sure what file to get nor am I sure at how to install the update
09-13-2011 09:36 AM
xsdbs I also agree with the use of the USB for those that don't have iPods and it is also nice to have a different music media choices. I just thought that the statement "just throw them away" was a useless comment.
The other thing is that people that have iPods have them for other listening applications as well as in the vehicle. However, YES it is sad that a highly desired media choice (APPLE) just seems to care less if the newest update (4.1 & up) causes issues. Uconnect just went thru a SW update that fixed the last APPLE issues. These issues were sent to APPLE and they did not write the fix, (they could have wrote the fix in 4.2), the sourcing company of Uconnect did (as well as the sourcing companies for other automotive companies) so now that the APPLE product can be used, they come out with a new update (4.3.5) and now there are new issues. As I have said before, "just because you can fix something does not mean that you broke it". Just like a doctor who puts your pins in your leg so you can walk again, he didn't cause your leg to be broken or crushed.
09-13-2011 09:17 AM
xsdbs When I do this I just open windows media player and select the music that I want to have on the thumb drive and then sync to the thumb drive. I don't do any converting.
I am no guru here an I am always open to learn something so if anyone can, please tell me if it does make a difference in sound quality by converting the file. Thanks in advance



Quote:
Originally Posted by 37Olivestreetbrews View Post
Do you have to convert your iTunes songs from aac to mp3 first when using the flash drive method?
09-13-2011 09:09 AM
xsdbs Yes there is, you would use the same update file that I had mrjeep post on page 13, reply 387 of the link below.


http://www.wranglerforum.com/f33/201...-88954-19.html




Quote:
Originally Posted by Djstorm100 View Post
Is there a way to update the people that don't have the navi just the plan radio with the uconnect?
09-12-2011 10:20 PM
Djstorm100 Is there a way to update the people that don't have the navi just the plan radio with the uconnect?
09-12-2011 08:34 PM
37Olivestreetbrews
Quote:
Originally Posted by ryankpreston

Don't necessarily agree with throwing away ipods, but I do agree that a USB flash drive is a pretty simple and easy answer to music storage in the jeep. I do it and it works perfectly. The songs and artists take about 10 minutes to load before you can access the data, but the music starts no problem and you can scroll through songs with the radio or steering wheel controls - piece of cake.
Do you have to convert your iTunes songs from aac to mp3 first when using the flash drive method?
09-12-2011 08:18 PM
ryankpreston
Quote:
Originally Posted by mchh11 View Post
This is the answer to fix all your ipods! ditch them. Go to bestbuy and buy a flash drive $40.00 and download all your songs, 16 gigs will get 800 songs and 32 gigs will get you 1800. You must have a ubs port to plug into its in my center console. I have 2011 with the 130 radio and the uconnect this works just like a ipod and you can use the steering wheel controls its awsome.
Don't necessarily agree with throwing away ipods, but I do agree that a USB flash drive is a pretty simple and easy answer to music storage in the jeep. I do it and it works perfectly. The songs and artists take about 10 minutes to load before you can access the data, but the music starts no problem and you can scroll through songs with the radio or steering wheel controls - piece of cake.
09-12-2011 07:10 PM
xsdbs I am starting to think possiblly a radio issue. The reason I am thinking that is because you say the USB thumb drive is lighting up and also the iPod is showing "accessory connected). Can you take a picture of the top label of the radio so I can see the part number of the radio?
When you try to "activate" streaming audio, what is the wording that you use?
It should be:
press the VR button and say "play Bluetooth streaming audio".
Did you get that iPod cable from the dealer or did you also have to order it online?




Quote:
Originally Posted by mlozano View Post
Hello

I bought the kit online in USA (Not available in Chile), installed myself and after that i went to the dealer to program the system. As i said, Bluetooth hands free works perfect with my iPhone 4, but Music is the problem.

I have checked everything again today, and all the cables are perfectly connected. The USB cable i'm using is Mopar P/N 82212160 and tried with OEM and aftermarket iPod USB Cable to dock connector.

Here is a pic of the module installed, also a picture of the screen on a 5th gen iPod nano connected to the Jeep.

Your questions:

1) when you plug in a USB thumb drive, does it light up?
Yes, it lights up.

2) on the iPhone 4, can you stream audio?
No, when i try to activate Bluetooth Audio trough the voice command, it switches the radio to AM or CD

3) if you have a iPod plugged in, press the VR button (next to the white phone button) and say "USB", what happens?
The same on bluetooth audio.

Any idea what can be the problem?.

Off course here in the local Jeep dealers nobody have idea... all said "you need to buy a 3.5mm cable and plug it in the aux port in front of the radio and in the headphone jack of your iPod"...

Regards

Mariano
09-12-2011 04:04 PM
xsdbs if you have an ipod or iphone,
please do not do the 4.3.5 update till i can test it. I have just been told by firewire (a member here) that there is a new problem with this update. I will be testing it and let you know more soon.
09-12-2011 04:02 PM
xsdbs Let me get back to you on this issue this evening okay.

Quote:
Originally Posted by mlozano View Post
Hello

I bought the kit online in USA (Not available in Chile), installed myself and after that i went to the dealer to program the system. As i said, Bluetooth hands free works perfect with my iPhone 4, but Music is the problem.

I have checked everything again today, and all the cables are perfectly connected. The USB cable i'm using is Mopar P/N 82212160 and tried with OEM and aftermarket iPod USB Cable to dock connector.

Here is a pic of the module installed, also a picture of the screen on a 5th gen iPod nano connected to the Jeep.

Your questions:

1) when you plug in a USB thumb drive, does it light up?
Yes, it lights up.

2) on the iPhone 4, can you stream audio?
No, when i try to activate Bluetooth Audio trough the voice command, it switches the radio to AM or CD

3) if you have a iPod plugged in, press the VR button (next to the white phone button) and say "USB", what happens?
The same on bluetooth audio.

Any idea what can be the problem?.

Off course here in the local Jeep dealers nobody have idea... all said "you need to buy a 3.5mm cable and plug it in the aux port in front of the radio and in the headphone jack of your iPod"...

Regards

Mariano
09-12-2011 12:30 PM
mlozano
Quote:
Originally Posted by xsdbs View Post
I must have missed the part about this being a dealer installed Mopar kit. Can you please post a picture of the black module located below the glove box opening. (open it and you should see the module). Did you install this or did the dealer? When the Mopar kit is installed the radio does need to be programmed for having added the Uconnect system.
1) when you plug in a USB thumb drive, does it light up?
2) on the iPhone 4, can you stream audio?
3) if you have a iPod plugged in, press the VR button (next to the white phone button) and say "USB", what happens?
Hello

I bought the kit online in USA (Not available in Chile), installed myself and after that i went to the dealer to program the system. As i said, Bluetooth hands free works perfect with my iPhone 4, but Music is the problem.

I have checked everything again today, and all the cables are perfectly connected. The USB cable i'm using is Mopar P/N 82212160 and tried with OEM and aftermarket iPod USB Cable to dock connector.

Here is a pic of the module installed, also a picture of the screen on a 5th gen iPod nano connected to the Jeep.

Your questions:

1) when you plug in a USB thumb drive, does it light up?
Yes, it lights up.

2) on the iPhone 4, can you stream audio?
No, when i try to activate Bluetooth Audio trough the voice command, it switches the radio to AM or CD

3) if you have a iPod plugged in, press the VR button (next to the white phone button) and say "USB", what happens?
The same on bluetooth audio.

Any idea what can be the problem?.

Off course here in the local Jeep dealers nobody have idea... all said "you need to buy a 3.5mm cable and plug it in the aux port in front of the radio and in the headphone jack of your iPod"...

Regards

Mariano
09-09-2011 10:42 AM
xsdbs Hello,
as well as buttons #2&3, #4 will give you genres.
Ok, now for the VR section, when you try to use it, can you tell me the wording that you are using please. Thanks


Quote:
Originally Posted by ryankpreston View Post
I loaded a 32 GB USB flash drive with a bunch of music and it plays perfectly. I can push #2 to scroll through artists and #3 to scroll through albums (or the other way around). I cannot get voice recognition to work well however, or at all actually. It doesn't seem to recognize artists or songs. Anyone have better luck with the voice command using a flash drive. I'm not an ipod user so have not experience there. SORRY if this was answered already.
09-09-2011 10:40 AM
xsdbs I must have missed the part about this being a dealer installed Mopar kit. Can you please post a picture of the black module located below the glove box opening. (open it and you should see the module). Did you install this or did the dealer? When the Mopar kit is installed the radio does need to be programmed for having added the Uconnect system.
1) when you plug in a USB thumb drive, does it light up?
2) on the iPhone 4, can you stream audio?
3) if you have a iPod plugged in, press the VR button (next to the white phone button) and say "USB", what happens?

Quote:
Originally Posted by mlozano View Post
The mfg date is 04-11 and The Uconnect module installed is PN 82212159

Regards

Mariano
09-07-2011 02:55 PM
ryankpreston
USB storage stick successful

I loaded a 32 GB USB flash drive with a bunch of music and it plays perfectly. I can push #2 to scroll through artists and #3 to scroll through albums (or the other way around). I cannot get voice recognition to work well however, or at all actually. It doesn't seem to recognize artists or songs. Anyone have better luck with the voice command using a flash drive. I'm not an ipod user so have not experience there. SORRY if this was answered already.
09-07-2011 02:33 PM
mlozano
Quote:
Originally Posted by xsdbs
Can you take a picture of the MFG tag on the drivers door for me and post it? Thanks
The mfg date is 04-11 and The Uconnect module installed is PN 82212159

Regards

Mariano
09-07-2011 01:22 PM
xsdbs Can you take a picture of the MFG tag on the drivers door for me and post it? Thanks

Quote:
Originally Posted by mlozano View Post
I also have tried with a 8GB USB Drive and nothing happens. (Same with iPods)

My question is, the dealer have to activate the USB cable too or just the Uconnect Bluetooth module?

In my case, Bluetooth communication works perfect with my iPhone 4, but i can't make it play music trough USB.

Regards

Mariano
09-07-2011 01:20 PM
xsdbs Yeah, sure it did. Do you really think that all the SW is written in a common form? If this was true then any version of Android or Apple SW would always work fine. However it is a fact that several devices work fine until the device manufacturer comes out with a new update and then it causes problems with what was already working. SO, who created the problem? Not Uconnect, Ford Sync, OR any other Bluetooth car kit company. There is no way of knowing after a SW is written to perform with a vehicle what the device companies will write for an update.



Quote:
Originally Posted by MrTremere View Post
My $75 Chinese radio from Fry's worked great with all my Apple devices. Jeep just needs better software programmers to stay with current with API development.
09-06-2011 07:51 PM
MrTremere My $75 Chinese radio from Fry's worked great with all my Apple devices. Jeep just needs better software programmers to stay with current with API development.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC