Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Sway Bar Question

Join Wrangler Forum Today


Thread: Sway Bar Question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-03-2007 09:24 PM
Triple88a you are talking about the sway bar links right? Get quick disconnects and be done with it. I've heard many have problems with the stock links so why buy and replace with stock when you will replace them again when they brake.

http://northridge4x4.com/products.php?cat=172&nav=84

http://northridge4x4.com/proddetail.php?prod=CE-9141

http://northridge4x4.com/proddetail.php?prod=JKS-2000
.....
09-03-2007 08:14 PM
drummerwookie that happened when i had my ZJ. the front ones just wore out at the ball. it happens especially if you wheel it without disconnecting them bc every time you need to articulate the front axle, it just adds extra stress to the sway bar links that wouldnt be there had it been discoed
09-03-2007 08:04 PM
Jma20a i got a 99 with 80,000 miles and have not had that problem.
09-03-2007 01:14 PM
nicolas-eric i also had this twice on my old 99 TJ. that seems to be normal.
09-03-2007 01:09 PM
Buffalo97
Sway Bar Question

Hey everyone,

I discovered yesterday that my front sway bars are broken. The Bars separated at the ball. Now I can completley and easily fix these. I know this because I have fixed this twice already. (both sides) this will be the third time fixing them. My 97 has 109,000 and is stock. since it became my DD after I went back to college.

My question is.....Is this normal?? Not to mention the little red devil sat in the garage for a year and a half.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC