Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Check Guages Light

Join Wrangler Forum Today


Thread: Check Guages Light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-22-2011 12:45 PM
ticketmuffin The only thing that lost power was the radio, everything else seemed to be fine. The radio came back on and CEL went off. I am going to have someone check the connections later. This is the second time that happened within the week.
06-22-2011 12:14 PM
kjeeper10 Seems electrical (obviously) did you loose total power? I know when you start the jeep the CEL comes on and then turns off. Check the battery connection for corrosion and make sure it's tight.
06-22-2011 11:46 AM
jk'n BTW, welcome to Wrangler Forum.

This is a great place to learn about your jeep.

Very friendly and the moderators help to keep it that way.

Lots of helpful people and a fun place to hang out.

Don't forget to wave to other jeepers.

It's a tradition.

Good luck with your electrical glitch. Hope it is nothing. If it persists, I would start with checking for loose wiring, possibly a ground.
06-22-2011 11:42 AM
jk'n There you go, darn they are quick!
06-22-2011 11:33 AM
jk'n If you have a 2004 you should have posted this in the TJ forum to get a better response. I'll see if I can get them to move it over there.
06-22-2011 10:56 AM
ticketmuffin
Check Guages Light

Hi everyone!
Okay I am a new Jeep owner and new to the forum. I need some input of an issue I am having with my 2004 Jeep Wrangler with 34K miles on it. I only take it out on the weekend or use while my other vehicle is getting serviced. Well, the other day while driving the radio made a loud pop turned off then came back on and the check guages light came on. It did not see like I lost any power and all the guages seemed to be within "normal" range and within a few minutes the check guages light went off. Can anyone make any suggestions on what I should check first?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC