Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > tranny and tranny fluid questions

Join Wrangler Forum Today


Thread: tranny and tranny fluid questions Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-30-2011 04:12 AM
misweetrevenge i have an AX5
06-30-2011 12:38 AM
Undead-89 The AX-15 requires GL-3, it used to be GL-5, but the additives are corrosive to the metals in the trans, not sure if the AX-5 is the same.

If you have a BA10, Puegeot recommnds using 20/50 Motor Oil in it instead of gear oil. The gear oil seems to be rough on the synchros.
06-29-2011 11:18 PM
misweetrevenge
Quote:
Originally Posted by Turbocoop View Post
I did mine last weekend in the jeep I just bought, it also has an AX5. I took the filler plug out and a good amount poured out before I got the drain plug out so it was definitely overfilled, the fluid was also thick and milky so Im guessin water got in there. I drained it and filled it up to the filler hole with pennzoil synchromesh (about 4 qts). After that it has almost completely stopped grinding when shifting to second and it shifts way smoother, I recommend that fluid if youre gonna do it.

is there a weight i have to look for with the pennzoil synchromesh you used?
06-29-2011 06:00 PM
Beaver5
Quote:
Originally Posted by TwistedWhispers View Post
I believe that tranny calls for 75 90 weight. Was the tranny up to operating temp when u pulled the plug ? Because fluid expands when hot. Also definitely change the fluid I bet no one else ever did. I had problems getting into 2nd , I let the tranny drain over night refilled it and problem was gone but when I pulled my fill plug first to check the level it was low
Yes thats what the owners maual calls for but it is a misprint. Jeep part# for manual tranny is a 10/30 motor oil. You can use MT90 like alot of other folks do with much sucsess or redline MTL which is closer to 30 weight oil. I was running 75/90 royal purple and it shifted like hell. I drained it and filled with strait 30 weight rotella and it shifts great. Gonna fill up with MTL next time I change.
06-29-2011 07:39 AM
Undead-89 Over filling isn't as big an issue with manual trannys as it is with Autos, where it is a really big issue. For a manual, the oil is just there to lubricate the parts.

In an automatic, the fluids is what actually transfers the power through the transmission. Picture a fan in the front push fluid to turn a fan in the back.
06-29-2011 07:08 AM
TwistedWhispers I believe that tranny calls for 75 90 weight. Was the tranny up to operating temp when u pulled the plug ? Because fluid expands when hot. Also definitely change the fluid I bet no one else ever did. I had problems getting into 2nd , I let the tranny drain over night refilled it and problem was gone but when I pulled my fill plug first to check the level it was low
06-29-2011 06:06 AM
Turbocoop I did mine last weekend in the jeep I just bought, it also has an AX5. I took the filler plug out and a good amount poured out before I got the drain plug out so it was definitely overfilled, the fluid was also thick and milky so Im guessin water got in there. I drained it and filled it up to the filler hole with pennzoil synchromesh (about 4 qts). After that it has almost completely stopped grinding when shifting to second and it shifts way smoother, I recommend that fluid if youre gonna do it.
06-29-2011 01:21 AM
misweetrevenge is the mt 90 useable for an AX5? and is it affordable?
06-28-2011 08:29 PM
LaterJim Someone else will have to answer on the overfilled issue, but it's possible. If it was pouring out then there was definitely too much in there. As for the slipping, what weight oil is in there? I have noticed it takes a minute or two when it's cold to shift smoothly. I use redline mt 90 which is q bit thicker which helps in the cold weather. As for slipping in second gear could be caused by a loose shifter fork or shift linkage.
06-28-2011 06:00 PM
misweetrevenge ok thats what i thought. odd. i was on level ground and i opend it up to check it cause my trannys been makin a funny hum/whine sound and it started pouring out. if theres too much fluid in it will it cause damage or cause a whining noise? and it also slips out of second when its cold and im costing
06-28-2011 05:52 PM
LaterJim Yes the filler is on the side...you should flush it sounds like. You should fill up to where it starts to drip out of the filler hole on the side. I have the AX15 but I assume they are similar in this respect. Someone will correct me if I am wrong...
06-28-2011 04:59 PM
misweetrevenge
tranny and tranny fluid questions

i know this is a dumb ass question and i thought i knew the answer but im just double checking.

the filler hole is on the side?
drain hole is on bottom?
is there another hole ontop i dont know about?
and i was told your only supposed to fill the tranny up to the filler hole.
when i took the side plug out to check my tranny fluid it starting pouring out. i was on level ground. did i pull the wrong one?

and i have an AX5 tranny. (manual)
my fluid was real dark and smelt kinda burnt. should i flush the fluid?

and do manual trannys have oil coolers on them?

sorry for all the dumb ass questions. i dont know much about trannys

BTW i have a 93 2.5L 5speed

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC