Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Help!!! Please!!! Tail light nightmare!!!

Join Wrangler Forum Today


Thread: Help!!! Please!!! Tail light nightmare!!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-04-2011 01:34 AM
BillyLA How is it going with the tail light. Did you manage to fix it?
07-02-2011 09:47 PM
stimpy Yeah do what Billy says and switch the entire taillight assembly around and see what happens. You shouldn't have to do any additional grounding because when its bolted up that's the ground. It really sounds like the wires are shorting/grounding out because they are not connected correctly. If its still messed up I would follow the entire wire all the way up to see if its frayed anywhere.
07-02-2011 09:33 PM
ropanach Check and see if the bulb holder was put together right, if not when you twist the bulb in place the pins will only line up with one pin. I found that one building a trailor with all brand new lighting, Yes I chased my a$$ of for a week.
07-02-2011 09:30 PM
BillyLA Have you checked the tail light itself? Wire it up in the drivers side to see if it works. You can't always trust new things to work out of the box. Whats the voltage reading at the tail light?
07-02-2011 07:47 PM
Square_headlight_fan
Quote:
Originally Posted by stimpy View Post
First thing I would do is re-check the grounds. Then I would switch bulbs around with bulbs you know work. See if the problem changes or stays the same. Check out the plugs for corrosion and dirt make sure they are connected securely.
Thank you very much for the advise stimpy but i have done all that already. I am really stumped here. i bought a new pack of bulbs and they work. the grounds have been checked 4 times now or more. this really sucks man. i wanna get this jeep on the road really bad.
07-02-2011 07:36 PM
stimpy First thing I would do is re-check the grounds. Then I would switch bulbs around with bulbs you know work. See if the problem changes or stays the same. Check out the plugs for corrosion and dirt make sure they are connected securely.
07-02-2011 06:55 PM
Square_headlight_fan
Help!!! Please!!! Tail light nightmare!!!

Ok i know this is talked about all over the net but this is a little different in my mind. Anyways i have a brand new Build i am just finishing (years in the making) and my tail lights wont work so please read all of this before you try to help. Thanks!!!
Left/Drivers side: Right/Passenger side:
Brake light works Brake light Doesnt work
running light works running light works
Turn signal works Turn Signal Doesnt work
Reverse light works Reverse light works
Hazard function works Hazard Function doesnt work

This is driving me crazy and i have re-wired it several times now, just cant get it.

The light is a brand new light with brand new bulbs. I have checked the buld connections, they are new. I have the correct style bulbs. The light have three wires coming out of them. red,white and a green. The ground is internal and grounds through the bolts which i have made better by running a wire straight from the lights bolt/ground plate straight to the frame to know the ground was good.

ANY ADVISE??? Thanks in advance!!

Also for those of you who say switches: If the switch was bad could just the left side work? or wouldnt the whole system from the switch be bad? Brake or turn signal switches? If it was the brake switch wouldnt the entire brake light system be down? or could just the left sideor right side go out? crazy stuff.....

If any of you said the fuses: Wouldnt the entire system on the other side of the fuse be down? I dont know....example: if the fuse was bad or blown non of them would work not just the left side right?

I am thinking its just a supply wire but cant seem to track it with a meter even so it is something really weird here i guess. Seems to be a common problem also from what i can tell but everyone always has the same answers: Meter,bulb,fuse etc. etc. its not. if you have encountered this before please take the load off me please, i am about to burn my project and shoot it up with the 50cal

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:46 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC