Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > What I did to my YJ today

Join Wrangler Forum Today


Thread: What I did to my YJ today Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 11:59 PM
4angels Put my hard top back on for fall/winter.
Yesterday 11:21 PM
TennesseeYJ
Quote:
Originally Posted by Pittsburghwrangler View Post
Good video. I have been meaning to do that mod for a couple of weeks. Your video was awesome and I am finally going to do it tomorrow. So thanks for the motivation. Is there a reason not to leave the tube a little bit longer to prevent the gas overflow problem?
Thanks, glad you like it! Putting that little section back in is more of a bracing for that vent neck coming out of the tank. The tank is pretty stiff right there, so I'm not so sure it's actually needed. But it's easy enough to put a small section back in for a little added insurance. As for leaving it a bit longer, being that the tube was originally like 10" long. I'm sure extending it a few inches into the tank can't hurt. I've never had any issues of any kind doing this mod as I demo'd it.
Yesterday 09:39 PM
Pittsburghwrangler
Quote:
Originally Posted by TennesseeYJ View Post

Welll ... I just posted the vid last night. I've been meaning to do for a long time. Just never got around to it.

Also, You could have cut you a fuel pump access hole while you had the tank out. I've had my pump out a couple of times. I don't need to drop the tank to do it anymore. Cut the hole big enough to where the fuel pump assembly comes out. Cover it with a metal plate w/RTV around the edges.
Good video. I have been meaning to do that mod for a couple of weeks. Your video was awesome and I am finally going to do it tomorrow. So thanks for the motivation. Is there a reason not to leave the tube a little bit longer to prevent the gas overflow problem?
Yesterday 03:53 PM
djhatley
What I did to my jeep today

I finished hooking up my front sway bar quick disconnects, installed a aftermarket temp gauge, installed two 12 inch fans.
Yesterday 02:19 PM
TennesseeYJ
Quote:
Originally Posted by Fun sized View Post
Wish I had seen this when I had my tank out a few weeks ago
Welll ... I just posted the vid last night. I've been meaning to do for a long time. Just never got around to it.

Also, You could have cut you a fuel pump access hole while you had the tank out. I've had my pump out a couple of times. I don't need to drop the tank to do it anymore. Cut the hole big enough to where the fuel pump assembly comes out. Cover it with a metal plate w/RTV around the edges.
Yesterday 02:13 PM
Fun sized
Quote:
Originally Posted by TennesseeYJ View Post
Mine was like that for a long time right after I bought it. It would take 10-15 minutes or more to fill up! But in the past 6-8 months I haven't had any issues at all (I still can't go wide ope on the pump, but it's way better than before). I did this mod this past Sunday. Put gas in this morning, no issues, but like I said I hadn't in a very long time. I think it has a lot to do with how sensitive the pumps at the station are. I say this because, when I was having lots of trouble, some pumps were less trouble than others. This is an easy mod, takes less than an hour, so it's worth a shot.
Wish I had seen this when I had my tank out a few weeks ago
Yesterday 02:04 PM
TennesseeYJ
Quote:
Originally Posted by Fun sized View Post
This is pretty cool. The pump usually shuts off when I try to fill mine too fast now. I wonder if this would help that problem.
Mine was like that for a long time right after I bought it. It would take 10-15 minutes or more to fill up! But in the past 6-8 months I haven't had any issues at all (I still can't go wide ope on the pump, but it's way better than before). I did this mod this past Sunday. Put gas in this morning, no issues, but like I said I hadn't in a very long time. I think it has a lot to do with how sensitive the pumps at the station are. I say this because, when I was having lots of trouble, some pumps were less trouble than others. This is an easy mod, takes less than an hour, so it's worth a shot.
Yesterday 01:46 PM
mrkswthwrth
Quote:
Originally Posted by crash007 View Post
Finished the lift for the YJ. I had the rear lift installed and had to get the fronts done, so I did them Sunday. It's a Rubicon Express 2.5" lift but it looks like it gave me more like 4" versus 2.5"
I also did the RE 2.5, I gained 4 inches but my springs were past flat.
Yesterday 01:35 PM
crash007 Finished the lift for the YJ. I had the rear lift installed and had to get the fronts done, so I did them Sunday. It's a Rubicon Express 2.5" lift but it looks like it gave me more like 4" versus 2.5"
Yesterday 10:25 AM
Fun sized
Quote:
Originally Posted by TennesseeYJ View Post
Did the 15 to 20 gallon gas tank mod .. https://www.youtube.com/watch?v=I8CipgprhYA
This is pretty cool. The pump usually shuts off when I try to fill mine too fast now. I wonder if this would help that problem.
Yesterday 09:45 AM
TennesseeYJ Did the 15 to 20 gallon gas tank mod ..

https://www.youtube.com/watch?v=I8CipgprhYA
Yesterday 06:28 AM
twister4399
Quote:
Originally Posted by Danbury95yj View Post
Fixed my 95's heater. Thought it could have been the blower motor resistor or the fan itself. Turns out there was a corroded wire connection going to the blower motor.
Got to love those fixes.
Yesterday 05:42 AM
Danbury95yj Fixed my 95's heater. Thought it could have been the blower motor resistor or the fan itself. Turns out there was a corroded wire connection going to the blower motor.
09-14-2014 02:24 PM
RufBoy New Power Steering Pump, Belt and Alternator.

Power Steering Pump


Alternator
09-13-2014 06:16 PM
Fun sized Checked/re-did numerous connections trying to figure out why she wouldn't start the other day. Replaced starter wiring, new battery leads, oil/filter change. Installed tailpipe hanger and painted the entire tailpipe black with hi-temp spray paint.

Yesterday I got the quarter windows and vented installed in the hardtop. Need to re-do weatherstrip and then it'll be ready to go on the YJ....even if I'm not ready for hardtop weather.
09-13-2014 02:08 PM
twister4399 Put the hard top back on .
09-13-2014 12:47 PM
WrangledMike Put the new fuel pump in and mounted the tank and fired up my jeep for the first time. Runs rough so still have plenty of work to do
09-12-2014 01:27 PM
johnsonken1332
Quote:
Originally Posted by MyRed88 View Post
pics or it didn't happen
Lol
09-12-2014 01:16 PM
Axton Got a 3/8" thick custom cut plate then mounted the ENGO e9000 winch onto it, then welded the plate onto the bumper. Needed a place to mount my roller bearing for the cable so I cut up two 3/16" thick angle steel then welded it onto my bumper. I think it turned out great.

Now I have to decide between making a bracket to hold the solenoid box above the winch since its too tight or to mount it under hood.



Attachment 1480041
09-12-2014 01:05 PM
TigWizard Since I took the tip off my thumb yesterday, I won't be doing much. Maybe I can bribe my neighbor with a case of beer to change out my slip yoke and universals?
09-11-2014 05:58 AM
RawhideClab ^yeah. First one had a faulty voltage regulator and would spike for a couple of seconds then be fine for a few minutes then spike fine spike fine. So warranted that one and the second one charged for not even 5 minutes and died. I think I am gonna save up for a mean green one.
09-11-2014 12:13 AM
Cameraman
Quote:
Originally Posted by RawhideClab View Post
Finally on the third attempt I got a new alternator that works!
What do you mean 3rd attempt. They sold you two bad ones? ?!!
09-10-2014 11:53 PM
TennesseeYJ
Quote:
Originally Posted by AutobotWrangler View Post
Added an American flag. drove it on the highway and now its shredded. Also hit up the park and took a nap in my hammock. No longer need two trees to post up.



Nice lookin rig!!
09-10-2014 09:12 PM
AutobotWrangler Added an American flag. drove it on the highway and now its shredded. Also hit up the park and took a nap in my hammock. No longer need two trees to post up.



09-10-2014 09:03 PM
RawhideClab Finally on the third attempt I got a new alternator that works!
09-10-2014 06:23 PM
Kane21d Yeah, I want those headlights.

Can they do LED turn lights too?
09-09-2014 10:58 PM
freonburn Got stranded... Changed my alternator and battery... Still no start... Starter tomorrow.
09-09-2014 09:34 PM
Tyler92yj Wish I knew how form a I phone I need to edit my info too and change my profile pic maybe upu can help
09-09-2014 06:20 PM
MyRed88
Quote:
Originally Posted by Tyler92yj View Post
Well it's been a while since I posted recently did a 5 inch rear stretch with genright armor tank and sliders just finished up front tube fenders started soa lastnight can't wait for the new look
pics or it didn't happen
09-09-2014 05:18 PM
Tyler92yj Well it's been a while since I posted recently did a 5 inch rear stretch with genright armor tank and sliders just finished up front tube fenders started soa lastnight can't wait for the new look
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC