Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Funny Clutch Pedal Feeling

Join Wrangler Forum Today


Thread: Funny Clutch Pedal Feeling Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-14-2011 01:31 PM
kik Again, this is not normal. My 06 and now my 10 never had that problem. I would take it and let them check it. With the mileage being that low I wouldn't even attribute it to a "break in" period because other JK's, and mine, were fine out of the box. Let the dealer figure it out.
07-14-2011 10:12 AM
demarpaint I'd bring it in and have it checked, it could be a throw-out bearing, the pilot bearing, needs to be bled, or nothing at all. I'm assuming, [bad word] that the clutch is hydraulic, and can possibly have a bit of air in the system, which would need to be bled out.
07-14-2011 10:01 AM
JeepDirtyGirl It almost feels like a creak....but without the sound. I also noticed that the clutch seems to only do this on the last 1.0 to 1.5 inches of travel while letting it out and only occasionally while pushing it in. I have also noticed that while coming up to a stop sign/light, if I shift through the gears (from whatever gear I am in) right down to 1st and sit at the sign/light with my foot holding in the clutch and other foot on the brake, this "odd" feeling is not as noticeable when taking off from a stop. However, if I am coming up to a stop sign/light and push the clutch in and shift into neutral and let the clutch back out (coasting to a stop) and sit at the sign/light with just one foot on the brake and NOT pushing in the clutch, the "odd" feeling is more noticeable. And one more thing I noticed.....this "odd" feeling is not present on first starting up and driving in the morning after sitting in the driveway all night; however, it does start occuring about 10-15 minutes after driving. I don't mind the "odd" feeling and I could get used to it over time, I just want to make sure it's normal and that nothing is wrong with the clutch. Any advice or suggestions would be awesome!
07-13-2011 07:42 PM
kik We had an 06 TJ with a 6spd and the clutch felt the same on or off. The clutch in our 10 Rubi 6spd also feels the same on or off, and no different than the TJ. I would take it in. Sounds like there's a problem. I agree with Meatco.
07-13-2011 05:21 PM
Meatco1 Could be throwout bearing, or pilot bearing. Either one of these have somewhat similar symptoms. That being said, I would first check out the pilot bearing.

Respects,

Richard
07-13-2011 04:50 PM
desertgoose Please describe odd feeling as best you can. Is it like a pulsating or rough engagement feeling? Or, possibly feels like it engages in 2 different steps?
07-13-2011 04:47 PM
C.L. Could you provide a bit more info? "Odd feeling" is hard to diagnose... Stuttering? Grabbing, Slipping? Sticking? Hard/Soft?
07-13-2011 04:40 PM
tysalem
Quote:
Originally Posted by JeepDirtyGirl View Post
Actually, the more I sit here and think about it, I only feel this "odd" feeling after I have pushed the clutch in, shifted into 1st, and am letting the clutch back out to take off from a dead stop. I feel it while letting the clutch back out.
Hmmmm, still not sure what kind of odd feeling your getting. This is my first manual vehicle, so I don't have too much to compare it with, except my step mom's Corvette which I learned to drive on. That's completely different though.
07-13-2011 04:36 PM
JeepDirtyGirl Actually, the more I sit here and think about it, I only feel this "odd" feeling after I have pushed the clutch in, shifted into 1st, and am letting the clutch back out to take off from a dead stop. I feel it while letting the clutch back out.
07-13-2011 04:27 PM
tysalem I'm not quite sure what the problem is. I have a 2 door six speed and I don't notice any difference between the clutch pedal operation when the jeep is running not. My suggestion is to head to the dealer and test drive an identical jeep and see if it's the same. If it is, you might just have to deal with this "odd" feeling. If not, then have the dealer take a look at it.
07-13-2011 04:15 PM
JeepDirtyGirl
Funny Clutch Pedal Feeling

Hello All!

I am new to this forum and have had my 2011 Natural Green/2 door/6- speed/soft top JK Sport for about a week now (it has 300 miles on it) and I LOVE LOVE LOVE it!! I previously owned a 6-speed 2006 TJ 2 door soft top, but sadly had to get rid of it due to multiple problems.

Here is my question:

When the Jeep is off (totally not running) and just sitting in my driveway, I can push in and release the clutch without a single sound or odd feeling in the clutch pedal. However, when sitting at a stop sign/stop light I often feel an odd feeling in the clutch pedal when pushing it in/letting it out to shift to 1st to take off and feel it again while shifting between 1st and 2nd. I do not actually hear a single squeak, squeal, rattle, etc. but just notice an "odd" feeling in the pedal. Shifting between 3rd through 6th does not seem to produce this feeling. Is this a normal feeling with the clutch pedal? I can't recall if my '06 TJ did this or not. I have driven a manual trannny for about 20 years without any problems whatsoever, so I am sure it is not my driving causing this. Any advice would be really helpful.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:52 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC