Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Clutch problems.. very confused help please

Join Wrangler Forum Today


Thread: Clutch problems.. very confused help please Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-14-2011 06:13 AM
brian2869 the linkage from the pedal to the firewall should be your master cylinder. very simple fix.
06-06-2011 08:03 PM
abadoobi im pretty sure i figured out the problem. i broke the linkage from the petal to the fire wall. what part fixes this if anybody even knows? and how the hell do i fix it?
06-05-2011 11:54 PM
444 Refill it with brake fluid and start pumping the clutch to see if you can get it to build pressure. If it is leaking, you should get a helper to pump the clutch while you watch for leaks.
06-05-2011 10:40 PM
bigdog9801 Correct. I doubt you got air in your lines. I bet your slave cylinder is shot but that will be way way worse than just bleeding the lines and seeing if its low fluid (air in lines) or seeing if the master is shot. 93+ actually may be external slave cylinder which wouldnt be that bad either I suppose. Im not sure though on the years for external slave. Someone else on here would (or you could search).
06-05-2011 10:29 PM
abadoobi so if i just got air in the lines i would have to bleed it right? cuz isnt that a major PITA?
06-05-2011 09:47 PM
bigdog9801 First step is to refill and try to pressurize the system, if you cant then you would be leaking somewhere. Leak in the bellhousing = slave cylinder. Leak in a line = leak in a line. No leak but no pressure = master. If you add fluid and it re-pressurizes you are good to go. In my experience if you got air in the system (level got too low) it can take a while to re-pressurize...
06-05-2011 08:04 PM
abadoobi
Clutch problems.. very confused help please

ok so today i drove my 93 2.5 jeep to work at around 1:00pm everything was fine. no problems with the clutch. get off work go to the jeep and there is 0 pressure in the clutch i can just tap it with my foot and it goes all the way to the floor and pops right back up. didnt want to try to change gears cuz if i couldnt get it back in i would have been screwed. my e brake hasnt worked since i got it. what the hell is the problem. i have been reading around and i am thinking maybe the pressure plate master cylinder or slave cylinder? which do you suspect? also there i didnt get under the jeep as it was parked right on the main street and didnt feel like having some idiot run me over but i did check the fluid and it was low but still had a tiny bit in the resivoir. couldnt see any fluid below there but there was a ton of some kind of fluid on the ground in the front like right under the radiator but idk how the hell clutch fluid would get way up there. i dont have a fan shroud on so maybe it got to the fan and when i was driving and it threw it on the radiator and it slowly dripped off. could it have been leaking when i was driving to work and just finished leaking while parked there? the drive to work is less than 2 miles

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC