Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuel Pump problem?

Join Wrangler Forum Today


Thread: Fuel Pump problem? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-21-2011 04:09 PM
TuckerTighe Thanks to everyone for the help. Turns out it was a bad ground, got it running again today
07-20-2011 02:31 AM
SquareLite try swapping the auto shutdown relay under the hood. if your horn works, swap it. had a similar issue with mine. simple relay died.
07-19-2011 02:17 PM
TuckerTighe We did check the "air nipple" yesterday and no gas. My dad is pretty good with cars so I'm sure he could replace the fuel pump if needed, I'll look into the filter as Jmnem said also. thanks everyone for the help
07-19-2011 11:29 AM
Buddha If you don't hear the fuel pump hum for a second when you turn on the key you could have a bad ground. There's also a fuel pump relay somewhere that could be bad, but I would lean toward the ground because of the gauge issue you are having. I don't know much about either of them as I've never had the problem myself but if you look around on here you might find some threads that describe the issues. Here are a couple from another forum that might help:

Fuel Pump ground wire - JeepForum.com
gas gauge - JeepForum.com
07-19-2011 11:01 AM
Jmnem21 Like Brent said, check your "air nipple" (schrader valve) on your fuel rail on top of the engine. Push the needle in with a screwdriver. Then try to start it again. Push the valve back in with the screwdriver and see if there is any gas and pressure in the line. (watch your eyes for gas) If there is no gas in the line then your problem is more likely the pump or filter.

If you haven't changed your filter it would be a good idea to change that first. It's located almost underneath your seat on the underside of the Jeep. It's about the size of a Campbell's soup can. They are cheap and easy to fix. If that is not the problem then there is a good chance your pump is bad. Check those first and then we can help you further if it is your pump. Don't pay someone $400 to fix your pump!
07-18-2011 08:00 PM
brent in az You should have what appears to be an air nipple (it's not) near on top of your engine. That's fuel p.s.i. checker.

Those are the classic symptoms of a dead fuel pump, though. Especially when you stick the key in the ignition, crank up, and DON'T hear the hum of the pump kick in.

None of this advice is applicable at all if you have a carb and external fuel pump, however. I just don't know.
07-18-2011 07:17 PM
TuckerTighe
Fuel Pump problem?

Ok, so for the first time since I've owned my Jeep, it wouldn't start today, Even though I drove to the store earlier no problem. So, I go out to move it to wash it and it won't start, thought it might be out of gas even though the fuel gauge was reading half tank earlier so I put some about 5 gallons of gas in it. Still no luck starting. Also, when I try to start it now the fuel gauge goes all the way up past full. So my question is is it the fuel pump that's causing it? I don't know a lot about cars but my dad knows a pretty good amount but even he isn't exactly sure. Any help would be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC