Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > blower problems

Join Wrangler Forum Today


Thread: blower problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-19-2011 09:43 PM
bc3_Jeep I would try running a hot wire straight from the battery to the motor.....possible something is inside the housing preventing it from turning..... I have pulled all kinds of debris from inside those housings....
07-19-2011 09:27 PM
barjeep i know on g.m. there is a rheostat on blower motor housing that controls speeds on blower. should be couple wires going to it. dont; know if thats what you checked or not. dont; even know if jeep has such a thing or not without looking kinda dark out now.
07-19-2011 08:58 PM
jfbilbro Checked the fuse?
07-19-2011 08:13 PM
umpire72956
blower problems

i have a 2000 cherokee and the blower motor wont run. i have replaced the blower motor, resistor ans ac control switch and still no blower. you can hear compresor run and feel cold air but blower will not run any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:23 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC