Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > is my thermostat bad ?

Join Wrangler Forum Today


Thread: is my thermostat bad ? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-12-2011 10:24 PM
speed goat 1 Thermostat test at about 200 deg the thermostat will open ,the top hose will become hot to top radiator inlet.
2 check if radiator is plugged,Remove radiator fill with water from lower hose inlet garden hose and rag wraped around hose.Water will spew out of radiator about 1 ft and empty radiator in about 3 seconds if clean.
3 If clutch fan is bad will over heat in slow city driving.Also check if radiator core is plugged with bugs.Car wash time.
4 Have block test done on the cooling system.Cheap insurance
08-12-2011 06:00 PM
drhodes You can also pull the thermostat to and run without one to see if its the thermostat that's the problem. But it could be a lot of things the cooling system is temperamental
08-12-2011 05:35 PM
Wantstojeep you might want to check the Radiator if it is plugged up from having a head gasket fail. easy to do let the engine get to operating temp then feel the Rad (On the Front not by the fan) up and down and right and left. if you have a IR temp gun you can check it that way too.
08-12-2011 05:14 PM
onroad Easiest way I've found to fill the 4.0 is to warm it up enough to open the stat, jack up the front axle till the front end is on a good incline, and hold the upper radiator hose down so it's lower than the filler neck. That "hump" in the upper hose traps an air pocket. Pull it down enough to be on a downward slope from the radiator tank, but not so much you're kinking it off, and the coolant will flow right down into the block and the air will burp out.

Fill the radiator till the upper tank is full right to the brim of the filler, pull the hose down and watch the coolant level drop, you can feel the air burping up through the hose, and keep repeating until the upper tank stays full.
08-12-2011 04:38 PM
2xs Its easier to go buy a 12$ t stat then it is co check it.

Last time I changed my water pump, i had issues purging the air out of the system, So instead of being lazy I used my "Air-Evac Radiator Purge & Test System" cooling system filler tool and got it right.

Mac Tools Online Store - Air-Evac Radiator Purge & Test System
08-12-2011 03:53 PM
Xpress Put the t-stat in a pot of water, and put it on the stove. Let it go to a boil. It should open just before it boils if it's a 195*F t-stat.

Also make sure there is a tiny pin hole that air can bleed through with. Mine didn't have one, and it was causing an air bubble to be trapped behind the t-stat, keeping it from opening. Position the pinhole ontop so the coolant will touch the t-stat.
08-12-2011 02:13 PM
Jdobel Bypass the heater core to see if there is blockage maybe??
08-12-2011 10:24 AM
krida I also found out that he did replace the thermostat, so we are troubleshooting the other things, to make sure there are no air pockets, etc.
Thanks for your responces!
08-12-2011 10:22 AM
krida We had to order it from a Jeep dealership it was like 60 bucks. If it breaks again... it will be welded. I dont see why it couldn't be in the future.
08-11-2011 12:40 PM
Garyk As 4x4 said, change the thermostat, its cheap....also make sure there is no air in the cooling system.

Where did you get the engine mount bracket for the passenger side???
08-11-2011 12:30 PM
4x4mike The only way to see if the thermostat is bad is by taking it out, so since you have to take it out anyways might as well replace the cheap little part and gasket while you are at it.
08-11-2011 10:28 AM
krida
is my thermostat bad ?

So after buying the 1991 YJ, we realized there was a bad head gasket, purchased the kit and replaced everything. Found out the cylinder head was seriously warped and had a maxnaflux test done on it to check for cracks (no cracks, yeah!) and then had it Resurfaced. Needed a new water pump and also the front passenger side bracket under the engine mount was broken and had to be special ordered and replaced. All new fluids, etc. Jeep is running, sounds better, runs better, still slowing down a bit on inclines... but the big problem is the thermostat... it seems to be working, but goes up and down and almost over to the red...

Does anyone have any suggestions? Do you think the thermostat is bad? How can we check to see if its functioning properly?

Thanks for any advice !!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC