Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Motorcraft 2150 carb questions.

Join Wrangler Forum Today


Thread: Motorcraft 2150 carb questions. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-11-2011 07:33 PM
Michael L. just checked and there isn't a cat converter on there at all. although the tranny hump does get pretty warm. but yeah it refuses to go past 1300revs in 5th.
08-11-2011 07:05 PM
88Sahara Its a way to bypass the computer and get rid of most of the vacuum lines. There are some posts on here that have details.

You might also consider a clogged Cat Converter. This can cause the same symptoms. Engine will just feel like it won't go over a certain rpm no matter how far you push the go pedal. This is often times accompanied by a warmer than usual transmission hump.
08-11-2011 06:48 PM
Michael L. never heard of a nutter bypass... care to enlighten me?
08-11-2011 06:38 PM
yj93ben Check for vacuum leaks. Nutter bypass?
08-11-2011 04:04 PM
Michael L.
Motorcraft 2150 carb questions.

so the PO of my 90' yj (4.2 I6) put on a mc2150 (1.08) in place of the old carter. it starts and runs alright. (idles a little rough probably just needs adjusting). But it just doesn't seem to have the power i want at highway speeds. i understand it isn't going to feel like a v8... especially with 33x12.50 swampers. but i can hardly make it do 60mph (wide open). ive done my research and as far as i can tell it's set up correctly.

is this normal with this carb/tires and engine?

and what are my options to add performance on this carb?
any comments or ideas are much appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC