Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Check engine light tranny clutch

Join Wrangler Forum Today


Thread: Check engine light tranny clutch Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-06-2007 09:37 AM
Odhinn Check all the connectors and wires in the area of the transmission/driveline. Without the code it is hard to say.
10-06-2007 02:28 AM
acopsy88
Check engine light tranny clutch

OK heres the scoop a few weeks back my jeep wouldnt go in to gear and would have problems. The dealer said 900 dollars to replace the clutch.(yeah right). Well i figured i could do it with the help of a couple buddies. Yeah we get it all installed new clutch no problems. I go take it for a spind works great. Then i take it out after work and head home pick my buddy up. WE take it for a test run i kind of get on it hit 2200 rpms in 3rd and it jerked it was in gear felt like if some one makes a crappy shift. I say ok keep goin it does it again. in third and fourth about 5 miles later. I go home and start the trek over again same route etc.. This time it doesnt do it and my check engine light comes on.. my gues is maybe a switch came undone.... I wouldnt think it was the transmission. check engine is usally electrical.. im going to run it by auto zone tomorow and see what they say... any ideas. thanks adam

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC