Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Bestop Hard top install problem

Join Wrangler Forum Today


Thread: Bestop Hard top install problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-27-2007 02:13 AM
thetoughguy i'll get some pictures so you can see what i'm talking about. there is a lot of tension on mine. i think that if i did shut it all the way the window would break. that's how far it is from fitting properly. you can see the whole top being pushed when i try to close the door. everything looks like it is lined up properly everywhere else, so i'm not sure what else to try.
10-27-2007 12:23 AM
ygohome on my oem hardtop, after setting it on the tub, I can push it forward or back a little either way. I'm wondering if you unbolt it from the tub and push it from the back forward... if that would give you the clearance you need.

Otherwise, take a couple pictures and post them on here... and you could also send those pictures to besttop and see what they say about it after they get a chance to see what your describing.
10-26-2007 11:32 PM
thetoughguy
Bestop Hard top install problem

Hi guys,

I just got a bestop hard top, and i'm having problems getting it installed properly. it actually should be easy, the top is on but I can not get the rear door to close properly. It seems to be marking contact with the rear glass much too early, making it impossible to close all the way. Has anyone run into this at all? everything else about the top looks like it is lined up properly. I called Bestop and they said to try to reseat the top again to see if that makes a difference. I tried that and nothing. any help is greatly appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:31 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC