Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Help anyone?

Join Wrangler Forum Today


Thread: Help anyone? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-03-2011 07:02 AM
WU05 Wow! Thanks Im definitely going to look into this. And now that I think about it I bet that is exactly what it is.
09-03-2011 06:04 AM
Shelby427 Back to the place that did the original work, and have em do it right.
From your description, you have pad(s) that aren't secure in the caliper, and or the pads were never bedded in properly.

I know when I changed ours recently, the pads came with a package of shims for the pads. There were instructions noting that the pads had to have the clearance checked between the pad itself and the caliper. There is a maximum of clearance allowed, .010-.015, above that and the pads will move around too much.

Also as stated, and our pads came with the instructions for doing this, was how to bed the pads to the rotors. Don't do it right and the pads form a glaze on the surface, and tend to be noisy.

Lastly, the quality of the pads can effect this, pads with no chamfer on the leading and trailing edges act like a plow as the rotor spins against them, causing them to squeal like fingernails on a chalk board.

The shops most likely are dumping a bunch of grease on the sliders, this dampens the vibration for a bit, but as soon as the grease wears down, back comes the noise.
Some techs out of laziness, grab the pads out of the box, and slam em in the caliper with no thought of what goes into a proper brake job. For them it's all about turning hours. Faster they get it done, more money they make. All fine and dandy till it turns around and bites em in the arse, and they get to fix it for free.
09-02-2011 10:18 PM
WU05 Yeah I ended up doing that one day but I didn't see any spots where it might be rubbing. This noise has me stumped.
09-02-2011 10:17 PM
SirGeorgeKillian Take the tire off on the side that is in question. Look at the rotor, see anything out of the norm?
09-02-2011 10:13 PM
WU05
Help anyone?

Okay so I have an 05 wrangler unlimited and for the past 4 months or so Ive been getting wierd noises coming from what I think is my front left tire. Its definately somewhere up front. Anyway it started after I got new brake pads and rotors installed. It was just a squeaking noise then but gradually it got worse so I took it back and they lubed it up real good but it didn't work so I took it to a different place and they took it all apart and cleaned everything and that made it go away for a while. But now I makes a faint grinding noise when I drive like a metal on metal noise and when I make a full left or right turn it squeaks very very loud and makes that grinding noise. I'm starting to get a little concerned. Any suggestions. I don't get any mysterious vibrations or anything its all just sound. I've personally looked at it and lubed it up numerous times but I have never seen anything that looked suspicious and my attempts at lubing it have failed. I could really use some help because this noise is honestly a little embarassing....

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:31 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC