Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Motor help

Join Wrangler Forum Today


Thread: Motor help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-02-2011 10:54 PM
yjdad Sounds to me like the engine is getting a little tired. First, I would evaluate the oil you are using, if the engine has a lot of time/miles it may be good to use 10w40 or something a little thicker than you are currently using. Second, as long as your lifters aren't ticking at idle speed, the rest of the engine is most likely getting enough oil to lubricate sufficiently. Last of all, changing engines is always fun!
09-02-2011 10:29 PM
ddavesyj
Motor help

Anyone know about oil presure problems. When I first start my 1989yj 4.2 I6 up it has 40-45 oi; presure. When it warms up to 180-190 degrees it drops to 20 at 2000 rpm and 5 at idol. shortly after it drops to 5 at 2000 rpm and 0 at Idol. When I let it set and cool down it starts at 40 again. I am wandering if my main bearing are shot. It allso leaks oil out of the rear main seel prety bad. Any ideas would be apriciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC