Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > What the heck can it be?????

Join Wrangler Forum Today


Thread: What the heck can it be????? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-05-2011 10:36 PM
Blackpony04 Sounds like wheel bearings especially if you hear it prominently when you turn slowly. My Pontiac Montana literally MOANED everytime I would turn it and that's what the issue turned out to be.
09-05-2011 09:17 PM
oIIIIIIo
Quote:
Originally Posted by distortedtj View Post
Also check the rear track bar.

Excellent point! Thanks....
09-05-2011 09:17 PM
mcsmcclain No, it's not lifted....it's really prominent when I turn to the left slowly if that makes a difference.
09-05-2011 09:15 PM
distortedtj Also check the rear track bar.
09-05-2011 09:14 PM
oIIIIIIo Welcome....

Is your jeep lifted?

I had the same problem too until I found out that it was my rear shocks relocation brackets. They were not tighten down enough. I removed it and put them back in with some loctite and problem solved.
09-05-2011 09:07 PM
mcsmcclain
What the heck can it be?????

Ok, I've had this popping noise coming from the back of my 1999 Jeep Wrangler for some time now. It doesn't do it all the time, just as the Jeep warms up and is driven for a while it starts, especially when driving slow.

I have replaced the rear brakes and calipers, shock absorbers and today (yes, all day) replaced the ujoints in the back. Still the popping! Could it be the rear wheel bearings.

So, I thought I may post before replacing every part on the dang thing and see if anyone else has had any experience with this problem.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC