Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Good mechanic needed.

Join Wrangler Forum Today


Thread: Good mechanic needed. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-15-2007 11:20 AM
soupy8728 After I swapped my engine, it did a similar thing. It was the clutch and I did NOT smell it burning. Good luck!!
11-12-2007 01:55 PM
reevesdieselyj I bet it is your timing. Adjust the distributor with a timing light. will probably fix it. have a good one.
11-12-2007 10:23 AM
4.0l sahara
Quote:
Originally Posted by dadstoys2 View Post
Sounds like a bad clutch from your description.
~Rich
If it was the clutch you would smell it burning if it's slipping that much. Do you smell it burning?
11-12-2007 10:21 AM
4.0l sahara check the ignition timing and if thats good check the cam timing. If the timing chain is off 1 or 2 notches on the gear it will run fine but will not have alot of power.
11-12-2007 12:06 AM
yj4x4 did you get the same size engine?
I was just wonderin cause i have seen it before
11-06-2007 05:09 AM
dadstoys2 Sounds like a bad clutch from your description.
~Rich
11-05-2007 08:28 PM
cab13guy
Quote:
Originally Posted by andok517 View Post
what does it do, when you say it feels like its in the wrong gear. explain?
Hi,

Before the engine swap-out the Jeep had some pick up… now when I set on the gas it feels like the parking brake is on. It has no go… the rpm’s go up but the truck is not moving as fast as it was before.
11-05-2007 08:13 PM
andok517 what does it do, when you say it feels like its in the wrong gear. explain?
11-05-2007 07:38 PM
cab13guy
Good mechanic needed.

Hello everyone!

Few weeks ago my 93 Wrangler I6 spun a bearing, looked around online for new engine. Found one for about $1500 with a nice warranty, had it delivered, swapped it out over the weekend but now the Jeep has no power (it fires right up, the engine sounds good, no smoke) but it feels like it’s in the wrong gear. Checked the compression, changed out all of the sensors, did a major tune up, but still no luck. Any suggestions? Or does anyone know a good mechanic around Plainfield IL area? Please let me know.

Thx.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:13 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC