Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Clutch Problem again

Join Wrangler Forum Today


Thread: Clutch Problem again Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-09-2007 10:27 AM
acopsy88 Really that couldpossible explain why it just all the sudden started acting up like that
11-09-2007 10:11 AM
mud707 I had a similar problem once in my CJ-5. It wouldn't want to go into gear until I started moving. Looked like a idiot pushing it a couple steps to get it in first. I took it to amco and they said it was the forks in the transmision wanted a grand to rebuild it. Took it to a local garage and they did it for 400.00. No problems after that.
11-09-2007 09:31 AM
acopsy88 Really hard like i have to shove my hardest to put in no grinding at all. you think it could be transmission fluid?
11-09-2007 07:33 AM
debruins hmm if it shifts fine once u get going i wonder if your tranny oil is too thick and now that its cold it is hard to shift??
what do you mean hard to get into gear, like grinding, or like you really have to push the shifter?
11-09-2007 12:34 AM
acopsy88
Clutch Problem again

Let me tellyouhow my day begins.I get upwait around for the semi to get here with my new PROCOMP XTREME M/T woo hoo right? Nope because as soon as i get in to my jeep it is really hard to put it in to gear i have to fight it. Which the reason i say again is because not even 2 months agoit did the same thing. The dealer said 900.00 its a burnt up clutch.I took it home bought one for 145.00 did it my self. Get it going it runs like a champ.Until today. I am not a bad clutch driver lol i have been driving a stick since i got my license. Never went througha clutch let alone 2.I was told it wasnt the syncros...but you cant really trust dealerships.... It is just really hard to get in to gear but once i start drivin it shifts ok.. Do you think their is air in my clutch system... Also on the old pressure plate the fingers were messed up pretty bad... I am going to on sunday drain all of the clutch fluid and replace is this a good start? ihave to drive it then as my dd. Help would be great also it is an 01 4.0 96000 miles

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC